none
In Point & Print Queue Can I execute Set-PrinterProperty -PrinterName printqueue1 -PropertyName "Config:Staple" -Value "Installed" RRS feed

  • Question

  • Hi,

    I have a point and print queue in my machine. Print Queue is XPS V4 driver.  Before creating point and print queue, I add the driver from "Printer Server Property" so that I can get my custom UI.

    Now In a Powershell which is opened in admin mode, I am trying to execute the following command.

    Set-PrinterProperty -PrinterName printqueue1 -PropertyName "Config:Staple" -Value "Installed"

    But it is getting failed. Due to the following queue.

    ------------------------------------------------------------------------------

    Set-PrinterProperty : The specified server does not exist, or the server or printer name is invalid.  Names may not
    contain ',' or '\' characters.
    At line:1 char:1
    + Set-PrinterProperty -PrinterName "PrintQueue1 on xx.xxx.x.xxx" -Pro ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (MSFT_PrinterProperty:ROOT/StandardCimv2/MSFT_PrinterProperty) [Set-Printe
       rProperty], CimException
        + FullyQualifiedErrorId : HRESULT 0x80070709,Set-PrinterProperty

    ----------------------------------------------------------------------------------

    But I have mentioned valid print queue name in command. How do I use the Set-PrinterProperty in Point and print queue. Is it at all possible?

    Regards,

    Monday, October 24, 2016 12:53 PM