none
Post Build Copy Not Working RRS feed

  • Question

  • I'm trying to follow along on a tut for documenting and API. getting an error not discussed in the tut

    error:

    Severity Code Description Project File Line Suppression State
    Error The command "copy C:\Users\mholmes\documents\visual studio 2015\Projects\SystemAPI\SystemAPI\bin\SystemAPI.xml C:\Users\mholmes\documents\visual studio 2015\Projects\SystemAPI\SystemAPI\\App_Data\SystemAPI.xml" exited with code 1. SystemAPI C:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets 4714

    Build Event:

    copy $(SolutionDir)SystemAPI\bin\SystemAPI.xml $(ProjectDir)\App_Data\SystemAPI.xml

    Tuesday, April 24, 2018 9:02 PM

Answers

  • I think I figured it out some what ... I put the file in the app data location my self and seems to compile now. I assume its suppose  to copy it using the command to put it in there but its ok. 
    • Marked as answer by old_School Wednesday, April 25, 2018 5:59 PM
    Wednesday, April 25, 2018 5:59 PM

All replies

  • Try removing the extra \  and note there are spaces e.g. visual studio 2015 which means "" around the path and file name


    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.
    VB Forums - moderator
    profile for Karen Payne on Stack Exchange, a network of free, community-driven Q&A sites


    Tuesday, April 24, 2018 9:52 PM
    Moderator
  • I fixed that I think but still getting an error 

    Post Build event command line:

    copy $(SolutionDir)SystemAPI\bin\SystemAPI.xml $(ProjectDir)App_Data\SystemAPI.xml

    HelpPageConfig

    config.SetDocumentationProvider(new XmlDocumentationProvider(HttpContext.Current.Server.MapPath("~/App_Data/SystemAPI.xml")));

    Build - XML documentation file: bin\SystemAPI.XML

    Error:

    Severity Code Description Project File Line Suppression State
    Error The command "copy C:\Users\mholmes\documents\visual studio 2015\Projects\SystemAPI\SystemAPI\bin\SystemAPI.xml C:\Users\mholmes\documents\visual studio 2015\Projects\SystemAPI\SystemAPI\App_Data\SystemAPI.xml" exited with code 1. SystemAPI C:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets 4714

    Wednesday, April 25, 2018 4:35 PM
  • I think I figured it out some what ... I put the file in the app data location my self and seems to compile now. I assume its suppose  to copy it using the command to put it in there but its ok. 
    • Marked as answer by old_School Wednesday, April 25, 2018 5:59 PM
    Wednesday, April 25, 2018 5:59 PM