locked
Error when Creating Web Gallery Site - MySQL Connector for .Net is required RRS feed

  • Question

  • I am trying to test out Joomla installtions in our new environment and get the following error when I click on the final install button.

    The application could not be installed:
    - Error while install application pack
    - Error while installing application package: The MySQL Connector for .Net is required in order to perform this operation.

    I have removed the 6.2.3 connector and installed 6.2.4 hoping that this would fix the issue. I have also completely removed and reinstalled MySQL and that doesnt help. We are running the latest WSP version and I need to get this going for a client demo later this week.

    Any ideas where this error is triggered or what to do to fix it would be appreciated.

    • Edited by Kevin Gibson Thursday, December 16, 2010 10:56 PM
    Wednesday, December 15, 2010 8:10 PM

Answers

  • OK I've solved the problem but not 100% sure how as there are a few variables involved here.  Once I have more time to test, I'll report back.

     

    In an effort to solve this problem, I decided it was time to install Wordpress manually.  Instead, I thought I'd try on the webserver via WebPI.

     

    When I tried to install wordpress it wanted to install the following dependencies:

    1. Wordpress 3.0.3

    2. MySQL Connector / .NET 6.2.3

    3. Wincache Extensions v1.1 for PHP v5.2

    3. PHP v5.2.17.

    Now the reason for the last one is because I'm running PHP v5.3.5 with Wincache Extensions v1.1 for PHP 5.3.

     

    Once I ran the installer, it generated an error when creating the user (that is because the db user and pass already exist).

     

    I went back in to WSP and ran the Web App Gallery Installer again and viola, it worked!  My Setup is as follows:

     

    Non-working configuration:

    Server 1: WSP Enterprise, IIS 7.5, no MySQL Connector for .NET installed.

    Server 2: IIS 7.5, PHP 5.3.5 (custom php.ini), no MySQL Connector for .NET installed.

    Server 3: MySQL Server v5.1.x, .NET Connector v6.2.4 installed.

     

    Working configuration (changes in Bold):

    Server 1: WSP Enterprise (dedicated): IIS 7.5, PHP 5.3.5, no MySQL Connector for .NET installed, WebPI v3.0.

    Server 2: Web Server: IIS 7.5, PHP 5.2.17 (default php.ini), .NET Connector v6.2.3 installed, WebPI v3.0.

    Server 3: SQL Server: IIS 7.5, MySQL Server v5.1.x, .NET Connector v6.2.4 installed, No WebPI.


    So rather than changing your PHP configuration if you can, I would recommend installing the .NET connector on your web server as well and see if that helps to solve your problem.  If it's already there, then rollback to PHP v5.2.17 and see how that goes.

    Jason.

     

    Thursday, February 17, 2011 4:24 AM

All replies

  • I have also tried setting the External MYSQL IP and URL to no avail. I also can connect remotely to the External Ip via SQLYOG so access is not an issue.

     

    Also if I connect to the website the following error is displayed Database Error: Unable to connect to the database:Could not connect to MySQL

    I assume this means that joomla was installed but the DB server was not reachable. No internal firewalling is taking place but the database is on a seperate server. I had tested this functionality with the original version of WSP and everything worked well. It is only since we have upgraded that this has become an issue.

    Wednesday, December 15, 2010 8:31 PM
  • I guess I can assume noone else has seen this issue? I cant do anything Database related via the CP and am at a dead stop until I get this issue resolved.
    Thursday, December 16, 2010 10:57 PM
  • how about if you try to create the db from the db page instead of from webappsgallery ?

    is your db port correct ?

    Monday, December 27, 2010 5:55 PM
    Answerer
  • If I try to manually create the DB or a DB user from the DB section I get the following error:

    Page URL: http://portal.vohss.com:9001/Default.aspx?pid=SpaceMySql5&mid=106&ctl=edit_item&SpaceID=43
    Logged User: serveradmin
    Work on Behalf: keving
    Hosting Space: 43
    Stack Trace: System.Exception: Exception of type 'System.Exception' was thrown.
    Page URL: http://portal.vohss.com:9001/Default.aspx?pid=SpaceMySql5&mid=106&ctl=edit_item&SpaceID=43
    Logged User: serveradmin
    Work on Behalf: keving
    Hosting Space: 43
    Stack Trace: System.Exception: Exception of type 'System.Exception' was thrown.
    Page URL: http://portal.vohss.com:9001/Default.aspx?pid=SpaceMySql5&mid=106&ctl=edit_item&SpaceID=43
    Logged User: serveradmin
    Work on Behalf: keving
    Hosting Space: 43
    Stack Trace: System.Exception: Exception of type 'System.Exception' was thrown.
    I looked at the MYSQL setup section under servers and do not see a port listed. Initailly with the current version the IP had a port appended to the end of it BUT several posts indicated to remove that from the mix as it was an issue that would be corrected later. Where else can I validate the port? It is simply the std sql port

    Wednesday, December 29, 2010 7:51 PM
  • You could remove the 6.2.4 connector and then download and install the 6.3.4 connector from here towards the bottom and select the file mysql-connector-net-6.3.4.zip ( Link ) and try again...
    Thursday, December 30, 2010 9:13 AM
  • I added the 6.2.4 connector and removed the prior version first. I also rebooted the MYSQL server following the install. When I try to create the joomla site now I get the following error:

    The application could not be installed:
    - Error while install application pack
    - Error while installing application package: The MySQL Connector for .Net is required in order to perform this operation.
    If I go under servers and click update on the MYSQL portion for this one server the process completes so it appears that the connector now installed isnt supported.

    I can however, now create a DB manually using the WP so we are making progress. I just need to get the one click stuff working now. 

    Thursday, December 30, 2010 2:53 PM
  • Hi Guys,  I'm having the same issue.  MySQL connector v6.2.4, MySQL v5.1.x on a separate server.  It's bringing up the exact same error reported just above.

     

    I can also create the DB and User manually.  In fact I've done that and attempted the WP installation again, by selecting an existing database and db user account and get the same error.  One thing I noticed in the log though was the following:

     

    00:00:00
    Package ID: 64
    00:00:00
    Site Name: stonetile.com.au
    00:00:00
    Title: WordPress
    00:00:00
    Version: 3.0.3
    00:00:00
    Download URL: http://wordpress.org/wordpress-3.0.3-IIS.zip
    00:00:00
    Author: WordPress
    00:00:00
    Last Updated: 12/14/2010 5:17:39 AM
    00:00:00
    AppPath: 
    00:00:00
    DbServer: 
    00:00:00
    Automatic Database Server PHP File: 
    00:00:00
    DbName: stonetilewp
    00:00:00
    Automatic Database Name PHP File: 
    00:00:00
    DbUsername: stonetiledba
    00:00:00
    Automatic Database Username PHP File: 
    00:00:00
    DbPassword: xxxxxx
    00:00:00
    Automatic Database Password PHP File: 
    00:00:00
    DbAdminUsername: 
    00:00:00
    DbAdminPassword: 
    00:00:00
    Connection String: 
    00:00:00
    Key1: jhuiglhgliikiklhhku
    00:00:00
    Key2: lkjflsjljslfjwjffjlsajfl
    00:00:00
    Key3: lsajflsajfljsfjlksejf
    00:00:00
    Key4: aldafilalfjlajfjlajfhy
    00:00:00
    SetAclParameter1: 
    00:00:00
    WSPResourceGroup: MySQL5

    Now notice that the DbServer is not specified? 

    I do have the internal IP set to localhost,3306 and External IP set to 172.16.2.220 (which is the only IP MySQL listens on).  Our routers route 172.16 networks from our webhosts so that isn't the problem.  Since I can create the DB in WSP, I'm assuming that this is not the problem in any case.

    Any ideas?

     

    Jason.


    Tuesday, February 15, 2011 2:12 AM
  • Jason,

     

    I hope we get some traction on getting the issue resolved. Sad to say 6 weeks later and mine is till toast. I have even rebuilt the 3 servers in the mix to no avail (2 web and 1 DB) - I guess no one uses this and if they do the dont build any db driven websites.

    Tuesday, February 15, 2011 2:32 AM
  • Agreed Kevin.  We went in to production about 3 weeks ago and this is our first reseller that found the problem - a tad embarassing, however, the client has been with us for years so is understanding... for now...

     

    If there's anything else I can look for or provide to this thread, then let me know.

     

    A few other things I have tried:

     

    1. Checked the eventlogs - nothing in there that reports a problem, exception or error.

    2. Checked the Audit Logs - No additional information is reported other that in my previous post.

    3. There is no additional technical information when the error is reported.

    4. Per a suggestion from a related thread, I changed the internal and external IP addresses to be the same, omitting the port number and that yielded no difference unfortunately.

     

    I'm sure that the lack of information in the Dbserver field would be the underlying cause of the problem - hopefully this should help to identify the issue.  Kevin are you seeing this also when you look in the audit log of WAG_INSTALLER / INSTALL_WEB_APP?

    Jason.

     

    Tuesday, February 15, 2011 6:36 AM
  • Jason, where do you find the log file you asked about? I have looked all over the Enterprise Server as I assumed it would be the logging point and cant find any sort of history or log files. I have about 10 total servers with all of the Exchange and Sharepoint stuff so if you can tell me where to look I will surley do so and post back.

     

    I suspect I will have the same issue with no DB listed but at least then we would be onto something.

    Tuesday, February 15, 2011 9:48 PM
  • Hi Kevin,

     

    In WSP once you login as serveradmin, click on the Audit Log which is on the LHS under the Account Menu, second option from the bottom with WSP v1.1.0.

     

    Make sure you select the date in the date picker based on when you last tried the install.  In the log, you should find INSTALL_WEB_APP in there (well hopefully).  This should contain the parameters that are passed to the wordpress installer I'm assuming.  If there are any other error related items in there, then this may help to further troubleshoot the issue.

     

    Tuesday, February 15, 2011 11:14 PM
  • Thanks, and to think I was looking for real logs the whole time.

     

    I get the same results when I review the last attempt - no DB Server listed:

    00:00:00
    DatabaseServer:
    00:00:00
    Automatic DatabaseServer:
    00:00:00
    DatabaseName: my_site_db_1atf
    00:00:00
    Automatic DatabaseName:
    00:00:00
    Database Prefix: jos_
    00:00:00
    Automatic db prefix:

    I have tried setting the MySQL IP to both internal and external as well as removing the port as it is default but nothing works. Sad thing is under 1.0 this worked fine and only since upgrading has the capability been killed to create the DB on the fly.
    Wednesday, February 16, 2011 1:27 AM
  • OK I've solved the problem but not 100% sure how as there are a few variables involved here.  Once I have more time to test, I'll report back.

     

    In an effort to solve this problem, I decided it was time to install Wordpress manually.  Instead, I thought I'd try on the webserver via WebPI.

     

    When I tried to install wordpress it wanted to install the following dependencies:

    1. Wordpress 3.0.3

    2. MySQL Connector / .NET 6.2.3

    3. Wincache Extensions v1.1 for PHP v5.2

    3. PHP v5.2.17.

    Now the reason for the last one is because I'm running PHP v5.3.5 with Wincache Extensions v1.1 for PHP 5.3.

     

    Once I ran the installer, it generated an error when creating the user (that is because the db user and pass already exist).

     

    I went back in to WSP and ran the Web App Gallery Installer again and viola, it worked!  My Setup is as follows:

     

    Non-working configuration:

    Server 1: WSP Enterprise, IIS 7.5, no MySQL Connector for .NET installed.

    Server 2: IIS 7.5, PHP 5.3.5 (custom php.ini), no MySQL Connector for .NET installed.

    Server 3: MySQL Server v5.1.x, .NET Connector v6.2.4 installed.

     

    Working configuration (changes in Bold):

    Server 1: WSP Enterprise (dedicated): IIS 7.5, PHP 5.3.5, no MySQL Connector for .NET installed, WebPI v3.0.

    Server 2: Web Server: IIS 7.5, PHP 5.2.17 (default php.ini), .NET Connector v6.2.3 installed, WebPI v3.0.

    Server 3: SQL Server: IIS 7.5, MySQL Server v5.1.x, .NET Connector v6.2.4 installed, No WebPI.


    So rather than changing your PHP configuration if you can, I would recommend installing the .NET connector on your web server as well and see if that helps to solve your problem.  If it's already there, then rollback to PHP v5.2.17 and see how that goes.

    Jason.

     

    Thursday, February 17, 2011 4:24 AM
  • Yes once I installed the 6.3.4 .Net Connectors on all of my balanced web servers it will now create the DB and finish the installation. Funny thing is it worked in the past without this being installed and the installation directions do not site a requirement to have the MYSQL Connector on the web servers. I guess they made some change in the last release and this is a new undocumented requirment now.

     

    I appreciate the assistance and am glad this is finally working now.

    My setup as it is now is

    Enterprice Server v6.3.4 MySQL COnnector

    Web Server 01 - IIS 7.5, php 5.2.15, .Net Connector 6.3.4

    Web Server 02 - IIS 7.5, php 5.2.15, .Net Connector 6.3.4

    SQL Server - MS SQL 2008R2, MySQL Server v5.1.x, .NET Connector v6.3.4

    Tuesday, February 22, 2011 3:54 PM