locked
Enterprice Library 3.0 (April 2007) issue - configuration won't save RRS feed

  • Question

  • User-782012840 posted
    Hello,

    I am trying to learn how to use Data Application Blocks from April 2007 release of Enterprise Library and faced this weird issue:

    I create a Class Library project,
    add app.config file to it,
    right click the app.config file and choose "Edit application library configuration" - it opens the Enterprise Library Configuration screen,
    Data Access application blocks branch is already there so I just change the "LocalSqlServer" connection string parameters,
    Choose file - "Save",
    close the solution and re-open it,
    the changes I made to app.config are not there - when library configuration tool is opened again - the settings from there are gone as well.

    Windows x64, VS 2005SP1.

    Can someone tell me what I am missing?
    Friday, April 13, 2007 5:16 PM

All replies

  • User-1302055314 posted

     u try this this will work properly

     

    public void AddData(string SCode, string SName,string SAddress,string STel)
            {

                SqlParameter[] param = null;
                param = new SqlParameter[2];

     

                param[0] = new SqlParameter(@SCode, SqlDbType.VarChar);
                param[0].Value = SCode;
                param[0].Size = 50;

                param[1] = new SqlParameter(@SName, SqlDbType.Char);
                param[1].Value = SName;
                param[1].Size = 20;

     

    SqlHelper.ExecuteNonQuery(StrConnection, CommandType.StoredProcedure, "Items_INSERT", param);

    }

     

    try this this will work

     

    Wednesday, May 14, 2008 7:33 AM