locked
SharePoint Site with anonymous access asks for credentials in Android device RRS feed

  • Question

  • I have a SharePoint (2013) public site with anonymous access which works fine when opened in pc/laptop.

    But when i try to open in any other device, it prompts for username and password.

    i used Responsive Web Design Tester extension for chrome to test this. (Also tested in my motorola android phone).

    If i click cancel for several times (cancel button on prompt), it opens the site but none of the images, js files and css are loaded. i see the console saying unauthorised for all these files.! I have a js code where it checks the navigator.useragent property and adds a css file if it is android/iphone/ipad.

    Also it doesn't prompt for credentials if i choose iPad!.

    What could be the issue.. any help would be appreciated.

    Tuesday, May 26, 2015 12:50 PM

Answers

  • Hi,

    According to your description, my understanding is that when you access an anoymous access enabled public site in Android Mobile Device, then the site still ask for user credentials.

    For mobie device, SharePoint automatically detects that a user is connected with a mobile browser, and redirects them to a mobile view of the page. However, by default anonymous users don’t have access to this page.

    In the case, I suggest you can not redirect user to mobile view page by changing the url.

    Another option is that set the mobile device check in web .config to false.

    Here is a similiar thread for your reference:

    Anonymous access for mobile users

    Here are some detailed articles for your reference:

    SharePoint 2010 Anonymous Sites Issues

    Thanks

    Best Regards


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, May 27, 2015 7:56 AM