none
Kernel mode debugger Error ? RRS feed

Answers

  • For it looks like you use Serial Port 2 for named pipe, Would set debugport in bcdedit command to 2 and restart the VM.

    With kind regards

    • Marked as answer by RightsTobe Tuesday, December 20, 2016 3:57 PM
    • Unmarked as answer by RightsTobe Tuesday, December 20, 2016 4:53 PM
    • Marked as answer by RightsTobe Tuesday, December 20, 2016 5:26 PM
    Tuesday, December 20, 2016 3:24 PM

All replies

  • For it looks like you use Serial Port 2 for named pipe, Would set debugport in bcdedit command to 2 and restart the VM.

    With kind regards

    • Marked as answer by RightsTobe Tuesday, December 20, 2016 3:57 PM
    • Unmarked as answer by RightsTobe Tuesday, December 20, 2016 4:53 PM
    • Marked as answer by RightsTobe Tuesday, December 20, 2016 5:26 PM
    Tuesday, December 20, 2016 3:24 PM
  • For it looks like you use Serial Port 2 for named pipe, Would set debugport in bcdedit command to 2 and restart the VM.

    With kind regardsT

    • Edited by RightsTobe Tuesday, December 20, 2016 5:26 PM
    Tuesday, December 20, 2016 4:53 PM
  • If the virtual machine is your target, it should have only one serial port, it is enough.

    Try to assign Serial Port 1 to \\.pipe\com1 and remove serial port 2 

    -- pa

    Tuesday, December 20, 2016 5:36 PM
  • If the virtual machine is your target, it should have only one serial port, it is enough.

    Try to assign Serial Port 1 to \\.pipe\com1 and remove serial port 2 

    -- pa

    IIRC, if it is VMWare (Player), then default settings, on machine-creation, configure/consume a (first) virtual serial port for printer communication.

    Probably I forgot to mention, name of pipe in 'Machine Settings' can be any valid pipename. E. g. \\.\pipe\foo . Just make sure, name of pipe at windbg cmd-args or in windbg's 'Kernel Debugging dialog box' matches the one, you use in machine settings.
     

    With kind regards
    Tuesday, December 20, 2016 7:17 PM