SSMS Options Reset to Default RRS feed

  • Question

  • Several times now, my SSMS options have been reset to their defaults.  I believe it is in conjunction with patching but I am not certain.  Has anyone else experienced this and is there a cure?  SSMS version is 10.50.1600.1.  Thanks!

    Monday, May 16, 2011 11:29 AM

All replies

  • Hi

    Does it occur on reboot or on opening of SSMS?


    Monday, May 16, 2011 3:24 PM
  • It happens very unpredictably.  I always reboot my PC when I leave work and I'll notice its happened when I come in the next day and start up SSMS.  I've spoken to a colleague and he has noticed this as well.  Both of us work remotely from time to time and my colleague thinks that may have something to do with it although I cannot imagine why.  I should try to document when this happens so I'll have a basis for any conclusions but it happens so sporadically that I haven't done that yet.  Its just REALLY annoying when it does.

    Monday, May 16, 2011 3:53 PM
  • What exactly mean by reset? Setting are saved under user profile. Is there any cleanup of user profile which happens during OS login?
    Balmukund Lakhani | Please mark solved if I've answered your question, vote for it as helpful to help other user's find a solution quicker
    This posting is provided "AS IS" with no warranties, and confers no rights.
    My Blog:
    Team Blog:
    Monday, May 16, 2011 4:01 PM
  • My recent servers list is gone and SSMS settings that I have customized have reverted to the default. For example the "Value for Select Top <n> Rows command" value gets set back to 1000. I am not aware of any cleanup being done on my user profile and other apps that store their settings are intact. That's what is so confusing.
    Monday, May 16, 2011 4:14 PM
  • I am also having this same issue and it seems to be related to OS patching, but again cannot confirm this.  Did anyone find a solution or work-around to the problem?


    Wednesday, August 31, 2011 1:59 PM
  • You must check you access to settings storage place: C:\Documents and Settings\<Username> \My Documents\SQL Server Management Studio\Settings

    And registry keys: HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server\90\Tools\Shell

    In case if you use roaming profile you must check your ability to store data in that folder and registry branch.

    Thursday, September 1, 2011 2:57 PM
  • This is still an issue for me.  Happened again last week.
    Monday, September 12, 2011 11:05 AM
  • Same here. Hoping someone who knows what's causing this and/or a solution stumbles on this thread. Thanks in advance if you do.
    Monday, September 12, 2011 1:43 PM