none
Setup.exe error when trying to install NET framework 3.5 RRS feed

  • Question

  • Hi,

    I need this version for running a programme that I need for work but it always gives me the error below, I have done a cleanup using this tool   blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx 

     and then downloaded and saved the v3.5 sp1, v1.1 and v1.1 sp1. Once downloaded I have tried to install them as  recommended in this post (sorry, in Spanish) but I keep getting the same error. I would really appreciate any help as it is key that I get this sorted by tomorrow.

    Thank you very much

    [06/29/13,23:43:33] Optional Component 'Microsoft .Net Framework 3.0': [2] Error code 1168 for this component means "Element not found.
    "
    [06/29/13,23:43:34] Optional Component 'Microsoft .Net Framework 3.0': [2] Component Optional Component 'Microsoft .Net Framework 3.0' returned an unexpected value.
    [06/29/13,23:43:34] Optional Component 'Microsoft .Net Framework 3.0': [2] Return from system messaging: Element not found.

    [06/29/13,23:43:56] WapUI: [2] DepCheck indicates Optional Component 'Microsoft .Net Framework 3.0' is not installed.
    [06/30/13,07:40:40] Optional Component 'Microsoft .Net Framework 3.0': [2] Error code 1168 for this component means "Element not found.
    "
    [06/30/13,07:40:41] Optional Component 'Microsoft .Net Framework 3.0': [2] Component Optional Component 'Microsoft .Net Framework 3.0' returned an unexpected value.
    [06/30/13,07:40:41] Optional Component 'Microsoft .Net Framework 3.0': [2] Return from system messaging: Element not found.

    [06/30/13,07:40:55] WapUI: [2] DepCheck indicates Optional Component 'Microsoft .Net Framework 3.0' is not installed.
    [06/30/13,08:48:44] Optional Component 'Microsoft .Net Framework 3.0': [2] Error code 1168 for this component means "Element not found.
    "
    [06/30/13,08:48:44] Optional Component 'Microsoft .Net Framework 3.0': [2] Component Optional Component 'Microsoft .Net Framework 3.0' returned an unexpected value.
    [06/30/13,08:48:45] Optional Component 'Microsoft .Net Framework 3.0': [2] Return from system messaging: Element not found.

    [06/30/13,08:49:02] WapUI: [2] DepCheck indicates Optional Component 'Microsoft .Net Framework 3.0' is not installed.
    [06/30/13,11:11:59] Optional Component 'Microsoft .Net Framework 3.0': [2] Error code 1168 for this component means "Element not found.
    "
    [06/30/13,11:11:59] Optional Component 'Microsoft .Net Framework 3.0': [2] Component Optional Component 'Microsoft .Net Framework 3.0' returned an unexpected value.
    [06/30/13,11:11:59] Optional Component 'Microsoft .Net Framework 3.0': [2] Return from system messaging: Element not found.

    [06/30/13,11:12:20] WapUI: [2] DepCheck indicates Optional Component 'Microsoft .Net Framework 3.0' is not installed.
    [06/30/13,13:35:21] Optional Component 'Microsoft .Net Framework 3.0': [2] Error code 1168 for this component means "Element not found.
    "
    [06/30/13,13:35:21] Optional Component 'Microsoft .Net Framework 3.0': [2] Component Optional Component 'Microsoft .Net Framework 3.0' returned an unexpected value.
    [06/30/13,13:35:22] Optional Component 'Microsoft .Net Framework 3.0': [2] Return from system messaging: Element not found.

    [06/30/13,13:35:40] WapUI: [2] DepCheck indicates Optional Component 'Microsoft .Net Framework 3.0' is not installed.

    Sunday, June 30, 2013 12:41 PM

Answers

All replies

  • Please tell us your Windows version and Service Pack level.

    Also, run this verification tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    After you run the tool, post the first 15 lines of the tool log here.

    Sunday, June 30, 2013 2:38 PM
  • Hi pvdg42,

    Thank you for your reply, I have a Windows Vista Home Premium with  a Service Pack 2

    The result of the verification is as below, I had just down a cleanup just in case it matters but I keep getting the same message

    [06/30/13,15:45:42] Beginning of new SetupVerifier activity logging session
    [06/30/13,15:45:42] Activity log file location: C:\Users\user\AppData\Local\Temp\setupverifier_main_06-30-13_15.45.42.txt
    [06/30/13,15:45:42] Error log file location: C:\Users\user\AppData\Local\Temp\setupverifier_errors_06-30-13_15.45.42.txt
    [06/30/13,15:45:42] Build created on September 10, 2012
    [06/30/13,15:45:42] Detected operating system: Windows Vista (x86)
    [06/30/13,15:45:42] For more information about repairing the .NET Framework, see http://support.microsoft.com/kb/2698555 and http://go.microsoft.com/fwlink/?LinkID=246062
    [06/30/13,15:45:42] Install state for .NET Framework 1.0: not installed.
    [06/30/13,15:45:42] Install state for .NET Framework 1.1: not installed.
    [06/30/13,15:45:42] Install state for .NET Framework 2.0: not installed.
    [06/30/13,15:45:42] Install state for .NET Framework 3.0: not installed.
    [06/30/13,15:45:42] Install state for .NET Framework 3.5: not installed.
    [06/30/13,15:45:42] Install state for .NET Framework 4 Client: not installed.
    [06/30/13,15:45:42] Install state for .NET Framework 4 Full: not installed.
    [06/30/13,15:45:42] Install state for .NET Framework 4.5: not installed.
    [06/30/13,15:45:42] Windows directory: C:\Windows
    [06/30/13,15:45:42] System directory: C:\Windows\system32
    [06/30/13,15:45:42] Program Files directory: C:\Program Files
    [06/30/13,15:45:42] Common Files directory: C:\Program Files\Common Files

    Thank you again for your help

    Sunday, June 30, 2013 2:54 PM
  • I'm sorry to be the bearer of bad news, but you have OS corruption issues.

    Why would I say that? Because .NET Framework 2.0 and 3.0 are installed as part of the OS.

    There is one technique for repairing embedded .NET Frameworks, described here:

    http://blogs.msdn.com/b/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx

    Note that if the procedure does not restore your .NET 2.0 and 3.0 so they show as installed when you rerun the verifier. your looking at OS repair/reinstall.

    Sunday, June 30, 2013 4:39 PM