none
Website Data Sources empty RRS feed

  • Question

  • I am using vs2008 website project

    When I tried to design a report viewer, I found the website data sources dialog box is empty. I am sure I have several objects created already.

    Then I go to Report menu -> Data Sources... , it gave me an error saying "Could not load file or assmbly.....or one of its dependencies. The system cannot find the file specified."

    I know I removed that referenced dll earlier but even when I add that dll back or remove. Data Sources keep complaining with this dialog box.

    I then try to do from the rdlc xml side. I mimic what my previous rdlc's xml and copy paste over. and try to run it. here is the xml's data source looks like:

    <DataSets>
        <DataSet Name="FoodCountObject">
          <Fields>
            <Field Name="Bureau">
              <DataField>Bureau</DataField>
              <rd:TypeName>System.String</rd:TypeName>
            </Field>
            <Field Name="Worker">
              <DataField>Worker</DataField>
              <rd:TypeName>System.String</rd:TypeName>
            </Field>
            <Field Name="CaseNumber">
              <DataField>CaseNumber</DataField>
              <rd:TypeName>System.String</rd:TypeName>
            </Field>
            <Field Name="Name">
              <DataField>Name</DataField>
              <rd:TypeName>System.String</rd:TypeName>
            </Field>
            <Field Name="FoodBox">
              <DataField>FoodBox</DataField>
              <rd:TypeName>System.Nullable`1[System.Int32]</rd:TypeName>
            </Field>
            <Field Name="MaleBox">
              <DataField>MaleBox</DataField>
              <rd:TypeName>System.Nullable`1[System.Int32]</rd:TypeName>
            </Field>
            <Field Name="FemaleBox">
              <DataField>FemaleBox</DataField>
              <rd:TypeName>System.Nullable`1[System.Int32]</rd:TypeName>
            </Field>
          </Fields>
          <Query>
            <DataSourceName>DummyDataSource</DataSourceName>
    		  <CommandText/>
            <rd:UseGenericDesigner>true</rd:UseGenericDesigner>
          </Query>
    		<rd:DataSetInfo>
    			<rd:ObjectDataSourceType>ECFAssistance.ReportHelper, ECFAssistance, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null</rd:ObjectDataSourceType>
    			<rd:ObjectDataSourceSelectMethod>GetFoodCount</rd:ObjectDataSourceSelectMethod>
    			<rd:ObjectDataSourceSelectMethodSignature>System.Linq.IQueryable`1[ECFAssistance.FoodCount] GetFoodCount(System.Nullable`1[System.DateTime], System.Nullable`1[System.DateTime])</rd:ObjectDataSourceSelectMethodSignature>
    		</rd:DataSetInfo>	
        </DataSet>
      </DataSets>

    When I ran it, it complains this:

     

  • An error occurred during local report processing.
  • The definition of the report 'Main Report' is invalid.
    The data set ‘FoodCountObject’ refers to the data source “DummyDataSource”, which does not exist.
  • can someone help me what's going on here? how to fix it?

Wednesday, April 7, 2010 8:38 PM