none
Creating Standard Storage account from azureCLI hangs

    Question

  • I have tried to create this more than once and it happens intermittently, but it suresly happens 2 out of 3 times... When you create a storage account, we have not created any containers or blobs or tables or any such thing. I understand the account creation also requires keys to be generated but you would think this process would get done fairly quickly. But when I have to wait for 20 minutes, this seems like there is a problem. Eventually it does complete but don't understand why sometimes it works quicker than most times when it just hangs... Here is what you see from the CLI

    Thanks for your help... Cheers! Ravi

    $ azure storage account list
    info:    Executing command storage account list
    + Getting storage accounts
    data:    Name                  SKU Name      SKU Tier  Access Tier  Kind     Encrypted Service  Location  Resource Group
    data:    --------------------  ------------  --------  -----------  -------  -----------------  --------  --------------
    data:    scriptengine20161121  Standard_LRS  Standard               Storage                     westus2   script_engine
    data:    scriptenginediag293   Standard_LRS  Standard               Storage                     westus2   script_engine
    data:    scriptenginedisks910  Premium_LRS   Premium                Storage                     westus2   script_engine
    info:    storage account list command OK

    $ azure storage account show scriptengine20161121
    info:    Executing command storage account show
    Resource group name:  script_engine
    + Getting storage account
    data:    Name: scriptengine20161121
    data:    Url: /subscriptions/3f9b4f7c-edee-4fe6-86ed-71db169e6c8f/resourceGroups/script_engine/providers/Microsoft.Storage/storageAccounts/scriptengine20161121
    data:    Type: Microsoft.Storage/storageAccounts
    data:    SKU Name: Standard_LRS
    data:    SKU Tier: Standard
    data:    Kind: Storage
    data:    Resource Group: script_engine
    data:    Location: westus2
    data:    Provisioning State: Creating
    data:    Primary Location: undefined
    data:    Primary Status: undefined
    data:    Secondary Location: undefined
    data:    Creation Time:
    info:    storage account show command OK



    Monday, November 21, 2016 11:13 AM

All replies

  • Hi,

     

    Thank you for posting here!

     

    I executed the same Azure CLI commands shown in your example but I did not observe any delay in the execution. What package of Azure CLI are you using? I tried it on the Windows version 0.10.7.

    Even storage account creation via CLI seemed quick. If it is an intermittent issue it could also be due to any local network latencies.

     

     

    Regards.

    Md. Shihab

    Tuesday, November 22, 2016 4:55 AM
  • Thanks for your answer. I am running this from Linuix and the Azure CLI version is 0.10.5.

    I have tried this a number of times as part of my work and not just one time. I have tried this both in standard and premium storage tiers (LRS and PLRS). As I said it works quickly sometimes but takes a long time to complete in many other times. It is not a local network issue because I can see (and show as I posted in the link above) that the "storage account" remains in the Provisioning State of "creating" for a long time.

    If you want to kick things under the rug that's your prerogative but my reporting is aimed at helping you improve your product and so you don't get any points for being defensive about this. Cheers.

    Wednesday, November 23, 2016 5:34 AM
  • Hi Ravi,

    I checked this with our internal teams and was told that they'd need more information such as account creation time, XLS( production XL) etc.

    I recommend you to create a technical support ticket. The ticket enables you to work closely with the support engineers and get a quick resolution to your issue.

     

    Here is the link http://azure.microsoft.com/en-us/support/options/ to create support case.

    Regards.

    Md. Shihab


    • Edited by Md Shihab Tuesday, November 29, 2016 7:06 AM link added
    Tuesday, November 29, 2016 7:05 AM