locked
toolkit:DatePicker icons not showing RRS feed

  • Question

  • I have the datepicker in my wp7 app.  The date picker is working but the icons at the bottom of the datepicker don't show up.  I see two icons that have an x going through them.. the icon is the same for both icon place holders.  What have i not done that the icons don't show up.  Again.. the picker is working other than the icons.

    the version of the Microsoft.Phone.Controls.dll is 3.0.30701.2350 with a date of 9/1/2010.

    thanks
    shannon
    Wednesday, November 2, 2011 2:03 PM

Answers

  • under the root of the project you need to create a directory called "Toolkit.Content"
    Now copy from the dark theme icons for check and cancel and name them "ApplicationBar.Check.png" and "ApplicationBar.Cancel.png".
    (C:\Program Files (x86)\Microsoft SDKs\Windows Phone\v7.0\Icons\dark)

    Include them in your project by right clicking and selecting include in project.
    finally set build action to Content.
    Wednesday, November 2, 2011 2:41 PM
  • okay

    1) uninstall app and install it again.

    if that doesn't work

    2) change build action to resource. deploy, change back to content and deploy again.
    Wednesday, November 2, 2011 3:28 PM

All replies

  • under the root of the project you need to create a directory called "Toolkit.Content"
    Now copy from the dark theme icons for check and cancel and name them "ApplicationBar.Check.png" and "ApplicationBar.Cancel.png".
    (C:\Program Files (x86)\Microsoft SDKs\Windows Phone\v7.0\Icons\dark)

    Include them in your project by right clicking and selecting include in project.
    finally set build action to Content.
    Wednesday, November 2, 2011 2:41 PM
  • I created the Toolkit.Content sub in the root of the wp7 app.

    Copied the AppBar.check.png and AppBar.Cancel.png to that folder

    renamed files to ApplicationBar.Check.png and ApplicationBar.Cancel.png

    selected each file and changed its build action to "Content"

    I did not see any include option when right clicking on the files from withing visual studio.  Those files exists now in the Toolkit.Content sub... The icons still don't show up.  I'm missing something... hope you will continue to assist.

    thanks
    shannon
    Wednesday, November 2, 2011 3:06 PM
  • okay

    1) uninstall app and install it again.

    if that doesn't work

    2) change build action to resource. deploy, change back to content and deploy again.
    Wednesday, November 2, 2011 3:28 PM
  • thanks for the help..what i did was
    1.remove the referrence for the toolkit. 
    2.installed NuGet
    3.opened up the NuGet Package Manager Console with my solution open
    4.from the console "Install-Package Silverlight"
    5.already had the icons there as you instructed... that got it working.

    thanks again for the help
    shannon
    Wednesday, November 2, 2011 3:59 PM
  • After you set Build Action to "Content" you also need to change when it copies to the device to "copy always" the first time you use them (after that you can change it back to not copy)
    Friday, February 10, 2012 4:07 AM
  • I think you got it working right?
    I think it's very simple steps like what Invoke IT Limited said:
    Right click on the image name, then select PROPERTIES, then in the Build Action, select Content (it may be default to Resource or something else)

    Cheers


    Friday, July 13, 2012 4:55 AM