locked
App terminates without warning RRS feed

  • Question

  • I have this app i'm working on and after the latest "update" (which i have not yet pushed onto the beta test), there seems to be something very bizarre going on.

    The app seems to terminate without any warning what so ever. Although it is still in beta stages, I use it for my day to day work, it worked perfectly fine till a few hours ago, when it simply refused to start up anymore. I press the icon, screen goes black (it has no splash screen because fast loading is crucial), stays like that for a couple of seconds, then crashes.

    Running it through the debugger shows nothing. The app crashes out of the blue, no exception is thrown.I suspected there might be an out of memory issue, but that is not the case. I run it with the memory profile test, and what is really bizarre is that it does not crash with the profiler running, neither does it show any exceptions or errors that I can see.

    What is up with that?

    PS: It appears it does not "crash" but rather go to the start screen for no apparent reason. The app is present in the backstack, and if i switch to it it loads correctly.
    • Edited by mcosmin Thursday, March 7, 2013 11:00 PM
    Thursday, March 7, 2013 10:58 PM

Answers

  • Oh well, I figured it out. There was a method eating a lot of processing time on the UI thread (moved it to background). It appears there is some sort of timeout before the system automatically deactivates your app.
    • Marked as answer by mcosmin Thursday, March 7, 2013 11:12 PM
    Thursday, March 7, 2013 11:12 PM