Microsoft Robotics Developer Studio 2008 CTP April Available RRS feed

  • General discussion

  • Microsoft announces the first Community Technical Preview (CTP) of Microsoft Robotics Developer Studio 2008. The preview contains a large number of new features and improvements including items such as:

    1. Improved security model with support for Message Level Authorization using Role-based access control allowing to fine-grained control of who can access services and how.

    2. Support for LINQ queries in DSSP subscriptions enabling applications to create complex queries that can be executed close to the data source instead of requiring moving data across the network 

    3. Support for creating applications that run on multiple DSS nodes using Visual Programming Language and DSS Manifest Editor. This makes it much simpler to create applications that run across nodes, either on the same machine or across the network. When an application containing multiple nodes is to be started, VPL creates individual deploy packages for each node and fires them up across the network.

    4. Support for record and playback functionality in Visual Simulation Environment enabling it to record the position and orientation of each entity and save that information to a file which later can be replayed.

    5. Support for storing simulation media resources such as texture maps, bitmaps, and mesh files directly as part of the CLR assemblies in the form of embedded resources rather than as external files.

    6. New Simulation floor plan editor which allows the user to put together walls, doors, windows, etc. to represent the interior of a room, house, or other building.

    You can also check out our detailed description of changes from previous versions.


    Please help us making this release better by trying it out and send your comments, suggestions, and bug reports to our MSDN forums.



    Wednesday, April 9, 2008 6:49 PM

All replies

  • I understand this environment is the next Microsoft Robotics Studio version, a kind of renamed MSRS 2.0 version. Is this right?


    Blog: http://lonifasiko.blogspot.com
    Thursday, April 10, 2008 7:01 AM
  • Congrats to the team for the CTP release!


    What do we need to do in order to migrate our current MSRS 1.5 services to Robotics Developed Studio 2008?




    Thursday, April 10, 2008 1:17 PM
  • Yup Smile


    Thursday, April 10, 2008 5:14 PM
  • You can run the DssProjectMigration command line tool which comes as part of RDS 2008 CTP1 -- it will update the project files to point to the new runtime. The easiest is to copy your 1.5 service projects under the RDS 2008 installation folder and then from the DSS Command Prompt run


    DssProjectMigration /s- "."




    Thursday, April 10, 2008 5:16 PM
  • Hello,


    I have some problems to get the new MS Robotics Developer Studio running. I installed it (the big package) but if I want to execute the Batch File for the "Basic Simulation Environment", I receive the following error message:


    Code Snippet
    Rebuilding contract directory cache. This will take a few moments ...
    Contract directory cache refresh complete
    *   Service started [04/11/2008 15:36:54][http://localhost:50000/directory]
    *   Service started [04/11/2008 15:36:54][http://localhost:50000/constructor/0b46f2dd-82b7-4414-85b6-3bdecb1f31ea]
    *   Service started [04/11/2008 15:36:54][http://localhost:50000/console/output]
    *   Starting manifest load: file:///C:/Microsoftfile:///C:/Microsoft">file:///C:/Microsoft</A< A>> Robotics Studio (2.0 CTP1)/samples/config/SimulationTutorial1.manifest.xml [04/11/2008 15:36:55][http://localhost:50000/manifestloaderclient]
    Rebuilding contract directory cache. This will take a few moments ...
    Contract directory cache refresh complete
    *** Manifest Loader: Creating service failed:
    Reason: Ein Aufrufziel hat einen Ausnahmefehler verursacht.    System.Reflection.TargetInvocationException: Ein Aufrufziel hat einen Ausnahmefehler verursacht.
    ---> System.IO.FileNotFoundException: Das angegebene Modul wurde nicht gefunden. (Ausnahme von HRESULT: 0x8007007E)
           bei Robotics.SimulationTutorial1.SimulationTutorial1..ctor(DsspServiceCreationPort creationPort)
           --- Ende der internen Ausnahmestapelüberwachung ---
           bei System.RuntimeMethodHandle._InvokeConstructor(Object[] args, SignatureStruct& signature, IntPtr declaringType)
           bei System.RuntimeMethodHandle.InvokeConstructor(Object[] args, SignatureStruct signature, RuntimeTypeHandle declaringType)
           bei System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
           bei Microsoft.Dss.Services.Constructor.ConstructService.InvokeServiceClas
           bei Microsoft.Dss.Services.Constructor.ConstructService.ReflectAndConstructService(ServiceCache Cache)
     [04/11/2008 15:36:57][http://localhost:50000/manifestloader/a484fb63-0628-428f-b490-415a7748dbee]
    *   Manifest load complete [04/11/2008 15:36:57][http://localhost:50000/manifestloaderclient]



    Sorry for the german error message, but I think the structure and the important parts don't differ from the english one.


    Before installing the Developerstudio, I uninstalled the Ageia software. MSRS 1.5 is still installed on my PC.


    When I tried to install the software at my laptop at home (running Windows Vista) all worked fine, but here under WindowsXP I can't get it running!


    Friday, April 11, 2008 2:00 PM
  • Congrat's on completing the new release.  Are all of the files within the "web download" (161.6 MB) contained within the "full download" (401.7 MB)?  If not, then which of the download installs should be ran first?


    Friday, April 11, 2008 2:11 PM
  • I have the same error under Vista 32bit as above. Here is the message in English:


    Code Snippet
    *   Service started [04/13/2008 02:46:08][http://pc:50000/direct
    *   Service started [04/13/2008 02:46:08][http://pc:50000/constr
    *   Service started [04/13/2008 02:46:08][http://pc:50000/consol
    *   Starting manifest load: file:///C:/Users/philipp/Microsoftfile:///C:/Users/philipp/Microsoft">file:///C:/Users/philipp/Microsoft</A< A>> Robotics Dev Stud
    io 2008/samples/config/SimulationTutorial1.manifest.xml [04/13/2008 02:46:09][ht
    Rebuilding contract directory cache. This will take a few moments ...
    Contract directory cache refresh complete
    *** Manifest Loader: Creating service failed:
    Reason: Exception has been thrown by the target of an invocation.    System.Refl
    ection.TargetInvocationException: Exception has been thrown by the target of an
    invocation. ---> System.IO.FileNotFoundException: The specified module could not
     be found. (Exception from HRESULT: 0x8007007E)
           at Robotics.SimulationTutorial1.SimulationTutorial1..ctor(DsspServiceCrea
    tionPort creationPort)
           --- End of inner exception stack trace ---
           at System.RuntimeMethodHandle._InvokeConstructor(Object[] args, Signature
    Struct& signature, IntPtr declaringType)
           at System.RuntimeMethodHandle.InvokeConstructor(Object[] args, SignatureS
    truct signature, RuntimeTypeHandle declaringType)
           at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAtt
    r, Binder binder, Object[] parameters, CultureInfo culture)
           at Microsoft.Dss.Services.Constructor.ConstructService.InvokeServiceClass
           at Microsoft.Dss.Services.Constructor.ConstructService.ReflectAndConstruc
    tService(ServiceCache Cache)
     [04/13/2008 02:46:13][http://pc:50000/manifestloader/5a36f251-7
    *   Manifest load complete [04/13/2008 02:46:13][http://pc:50000



    I did not have any MSRS installation before the 2008 CTP on this Vista box. Has there been anyone able to resolve this?





    Sunday, April 13, 2008 6:47 AM
  • I got my MSRS installation running by installing the following DirectX Redistributable(http://www.microsoft.com/downloads/details.aspx?familyid=740ac79a-5b72-447d-84f9-ee6407ed1a91&displaylang=en).

    Tuesday, April 15, 2008 11:05 AM
  • We accidentally installed this new version in C:\, without uninstalling MSRS 1.5 version and suddenly all robotics old projects that were up and running with MSRS 1.5 version, were not running anymore.

    Why? Cause this new installation changed all Visual Studio project properties pages in order to point them to new DssHost.exe location. Tried changing manually all paths to the older ones (MSRS 1.5), but there was no success at all. Finally solved it by uninstalling MSRS 1.5 and reinstalling it again.

    I understand this CTP version should let older projects unchanged unless user executes DssProjectMigration utility. Imagine you want to show a little demo with the old MSRS 1.5........

    Can MSRS 1.5 and MS Developer Estudio 2008 peacefully coexist? Any other incompatibilities?

    Just to let you know....

    Blog: http://lonifasiko.blogspot.com
    Tuesday, April 15, 2008 1:57 PM
  • Hi Miguel,


    Sure they can run side by side (but not simultaneously, i.e. you can't run DssHost from both versions at the same time).


    I have both versions installed on my PC and I can happily run a service from either of them. You have to install into a separate directory of course, and you have two different code trees, but there are no problems with co-existence.


    Did you install the new version into the same directory as the old one? This will definitely cause a problem.


    Just install the CTP of 2.0 into a different folder, not the V1.5 folder. The install now tries to take account of multi-user machines and put the installation under your Documents and Settings, but I don't like that so I changed the install point during the install to a top-level folder on my C drive.


    Then you can copy across your existing code under the new directory and run DssProjectMigration. That's all you have to do. All my code works fine except for a problem I have compiling Compact Framework projects, which probably will not affect you anyway.




    Wednesday, April 16, 2008 12:07 AM
  • That's the most strange one....did not install Robotics Developer Studio 2008 into same directory as MSRS 1.5.

    MSRS 1.5 was installed under "C:\Microsoft Robotics Studio (1.5)" and we, accidentally, installed MSRS 2008 Edition just under "C:\" instead of "C:\Microsoft Robotics Dev Studio 2008" or whatever. Therefore, installation created "C:\bin", "C:\samples" and many other directories just under plain "C" drive, that seem to have corrupted MSRS 1.5 previous installation.

    Just wanted to warn people about where they install MSR Developer Studio 2008 during installation process. Specify a specific folder for the installation, for example, "C:\Microsoft Robotics Dev Studio 2008"; do not install it just under "C:\" or any other drive letter.


    Blog: http://lonifasiko.blogspot.com
    Wednesday, April 16, 2008 7:46 AM
  • Far better than the previous, I've got another one guys .......

    Because of that strange installation we made with Robotics Developer Studio 2008 under "C:\" drive, now all Visual Studio projects (both new and old, no matter if are Windows Forms, Smart Device, Robotics...), they point to "C:\bin" , the directory where Robotics Developer Studio 2008 left robotics assemblies. Must manually change output directoy in all my projects.

    Seems like installation write in the registry or in an environment variable all output should point now there. Incredible but true....This smells right now like an installation bug......

    Blog: http://lonifasiko.blogspot.com

    Thursday, April 17, 2008 7:57 AM
  • The reason why your 1.5 installation projects were changed is that we as part of the installation runs dssprojectmigration which looks for service projects in all folders under the installation folder. As you installed in c:\ we basically thought the 1.5 services (which are in a folder below) also should be converted. You can convert them back by opening an 1.5 command prompt and then run


    Code Snippet

    dssprojectmigration /s- /b- "."




    Tuesday, April 22, 2008 4:42 PM
  • Thanks for the tip that lets us downgrade services to 1.5 version.

    Anyway, although I more or less understand your approach of automatically running dssprojectmigration when installing this new version, I still don't see the reason for the installation changing the output of all Visual Studio related projects. I'm not talking only about robotic projects, I'm talking about Winforms, Console and ASP.NET projects for example.


    Blog: http://lonifasiko.blogspot.com

    Thursday, April 24, 2008 7:32 AM

    Thanks S@ilor,


    This worked for me

    Friday, May 16, 2008 2:34 PM


    ich habe auch das gleiche Problem wie bei dir,kannst du mir bitte erklären wie du diese Problem gelöst hast weil ich seit 2 Tage kämpe ohne Erfolg

    Tuesday, May 20, 2008 10:40 AM