none
Clickonce: ApplicationURI is null, but allow url parameters to be passed is set to true RRS feed

  • Question

  • I have a winforms application deployed via clickonce and would like to harvest querystring arguments for the purpose of sending clickable links with parameters. 

    I am using the method outlined at the documentation on the ApplicatioDeployment.ActivationUri Property, using ApplicationDeployment.CurrentDeployment.ActivationUri.Query to receive querystring parameters, but nothing is returned. 

    In Visual Studio "Allow URL parameters to be passed to application" is set to true, and the deployed .application manifest also has the line ` <deployment install="true" trustURLParameters="true" />. I am using  file:///C:\Users\..\Deploy\Test.application?testarg=123 to launch from windows explorer. 

    Is there anything I am missing? 

    Thanks in anticipation

    Tuesday, September 17, 2019 12:38 AM

All replies

  • Hi Sai_W,

    Thank you for posting here.

    Since this thread is related to clickonce, I will move it to ClickOnce and Setup & Deployment Projects forum to get support.

    The Visual C# forum discusses and asks questions about the C# programming language, IDE, libraries, samples, and tools.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, September 17, 2019 7:25 AM