locked
Can't Call a C# WinMD Project from a JavaScript Metro Style App

    Question

  • Hello there

    I have a solution comprising a JavaScript front end project and a C# WinMd project.  I have been successfully calling functions in the C# WinMd project from the JavaScript project for several weeks.  Earlier today I added a new function to the C# project, and now I cannot call any function in any C# Winmd project in any circumstance.  I always get the error "An attempt was made to load a program with an incorrect format".

    I have tried running a copy of my application which was working yesterday - this is now not working with the same error.

    I have followed through the walkthrough at http://msdn.microsoft.com/en-us/library/windows/apps/hh779077%28v=vs.110%29.aspx, describing how to call a routine in a C# project (compiled as a WinMd), from a front end JavaScript project.  This does not work with the same error.

    I have uninstalled my application, deleted all the bin and obj directories, and rebooted.

    Any help would be appreciated.

    Tuesday, September 11, 2012 12:36 AM

All replies

  • I can now run a previous version of the application, and use an older version of the C# project with my latest front end.  However, if I make any change to the C# project, even just adding some whitespace, or updating a service reference, I get the error "An attempt was made to load a program with an incorrect format".  I am still unable to create a new solution with a JavaScript front end and a C# WinMd back end with the same error.
    Tuesday, September 11, 2012 9:24 AM