locked
Teredo offline after KB935807 on Vista RRS feed

  • Question

  • My Vista changed the teredo behavior after applying the recent KB935807 security update. Before the update, the teredo network interface had IPv6 address and operated correctly. However, the interface now has no IPv6 address, and the "netsh" command says "offline" because "Client is in a managed Network". As it is often pointed out, I set the teredo client type "enterpriseclient" before and after the security update.

     

    Does anyone know how Vista recognizes it's in "managed network" ?

    sgk
    Friday, July 20, 2007 4:59 PM

Answers

  • Hello,

     

    Vista identifies a managed network using a number of heuristics; for example, it looks for a domain controller.  The Teredo client should not be enabled by default on an enterprise network, but since you're explicitly overriding it (setting the client to enterpriseclient), it should be working for you.  Let's see if we can figure out why it's having problems.

     

    First, we need to gather some information from Teredo.  Are you comfortable using regedit?  If so, you need to go to the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Tracing\IpHlpSvc key and change the value of EnableFileTracing to 1 (it should be 0 by default).  Pay attention to the value of FileDirectory in that same key: this is the directory where the logs will be placed.  Also, you may wish to increase the MaxFileSize value to 010000000.

     

    1. Now that you've enabled tracing, stop the service using "net stop iphlpsvc" from an elevated command prompt
    2. Delete the current logs from \Windows\Tracing (or whatever you changed the log directory to be)
    3. Start the service using "net start iphlpsvc" from an elevated command prompt
    4. Repro the problem: type netsh int ter sh st (verify that even though teredo client type is "enterpriseclient", you are still offline because of "Client is in a managed Network")
    5. Generate ipconfig output by typing ipconfig /all > ipconfig.txt
    6. Submit ipconfig.txt, the output of step 4, and the IpHlpSvc.log from \Windows\Tracing for us to examine.  Please note that these will have some personal information about your machine, namely IP addresses, DNS settings, etc.  If you don't feel comfortable posting this information in this public forum, feel free to send it to me privately at vbobov@microsoft.com.

    Thanks,

    Vladimir

     

     

    Tuesday, July 24, 2007 9:53 PM

All replies

  • Hello,

     

    Vista identifies a managed network using a number of heuristics; for example, it looks for a domain controller.  The Teredo client should not be enabled by default on an enterprise network, but since you're explicitly overriding it (setting the client to enterpriseclient), it should be working for you.  Let's see if we can figure out why it's having problems.

     

    First, we need to gather some information from Teredo.  Are you comfortable using regedit?  If so, you need to go to the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Tracing\IpHlpSvc key and change the value of EnableFileTracing to 1 (it should be 0 by default).  Pay attention to the value of FileDirectory in that same key: this is the directory where the logs will be placed.  Also, you may wish to increase the MaxFileSize value to 010000000.

     

    1. Now that you've enabled tracing, stop the service using "net stop iphlpsvc" from an elevated command prompt
    2. Delete the current logs from \Windows\Tracing (or whatever you changed the log directory to be)
    3. Start the service using "net start iphlpsvc" from an elevated command prompt
    4. Repro the problem: type netsh int ter sh st (verify that even though teredo client type is "enterpriseclient", you are still offline because of "Client is in a managed Network")
    5. Generate ipconfig output by typing ipconfig /all > ipconfig.txt
    6. Submit ipconfig.txt, the output of step 4, and the IpHlpSvc.log from \Windows\Tracing for us to examine.  Please note that these will have some personal information about your machine, namely IP addresses, DNS settings, etc.  If you don't feel comfortable posting this information in this public forum, feel free to send it to me privately at vbobov@microsoft.com.

    Thanks,

    Vladimir

     

     

    Tuesday, July 24, 2007 9:53 PM
  • I also ran into this problem, but was able to resolve it using netsh by first disabling the Teredo interface and then bringing it back up with the enterpriseclient option.  Prior to this, netsh also showed the type as enterpriseclient but offline, due to the "Client is in a managed network" error.






    Monday, August 20, 2007 7:19 PM