none
Audience targeting on navigation not working RRS feed

  • Question

  • Hello everyone,

    I recently came across a SPS 2010 (SP1) installation where audience targeting not working. I target a navigation link to a “SharePoint group” audience but people not member of that group still can see the link. I tried this on a team site with publishing features turned on and also on a publishing site both behaves the same way. I do the same steps on another 2010 farm and audience targeting works as expected.  

    Tried toggling navigation security trimming, audience targeting (from Site Collection Navigation Settings) without any luck. Any suggestions would be appreciated.

    Many thanks in advanced!


    BlueSky2010
    Please help and appreciate others by using these features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"


    • Edited by BlueSky2010 Thursday, April 12, 2012 5:56 PM removed word 'permission'
    Thursday, April 12, 2012 3:40 PM

All replies

  • Hi BlueSky2010,

    I am a bit confused by your post. You said that you permissioned a link, and that people who are not part of that permissions set can still see the link. If this is just a standard link in a Publishing-enabled (Current or Global Navigation) or in a non-Publishing (Quick Launch or Top Link bar), then the link will appear regardless of the permissions assigned to the site.

    Audience targeting is not technically security, merely obfuscation - it hides or shows things based upon a person's membership in an audience. So, if you wish to have the link not appear, you can either compile an Audience on a schedule and have it "hide" the link by promoting it only to that Audience, or you can create a SharePoint Security Group, use it to build an Audience, and then "hide" the link by promoting it only to that Audience.

    The sum total of this is that manually entered links do not trim automatically within SharePoint, whether or not Publishing is enabled...

    Hope this helps


    Troy Lanphier -- MCT/MCSE/MCITP SharePoint Server 2010 Administration -- Author: Microsoft SharePoint Foundation 2010 Inside Out -- http://blog.sharepointcookbook.com

    Thursday, April 12, 2012 4:00 PM
  • or you can create a SharePoint Security Group, use it to build an Audience, and then "hide" the link by promoting it only to that Audience.

    Hi Troy,

    Sorry re-reading my original post - now I see it's confusing (I'll remove the word 'permission'). I'm trying to display few links only to an audience (which is a SharePoint security group in my case). Attached link explains what exactly I'm trying to get out of it. Which is working on one farm but not on the other. Any troubleshooting ideas would be appreciated.

    Hope this clarifies things a bit more. :-)

    Thank you!


    BlueSky2010
    Please help and appreciate others by using these features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Thursday, April 12, 2012 5:28 PM
  • hmm...looks like I'm kind of unique with this audience issue. Any thoughts anyone?

    BlueSky2010
    Please help and appreciate others by using these features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Tuesday, April 17, 2012 2:26 PM
  • Hi Have you found any solution on this?

    Im facing the same issue in my Sharepoint Site.

    Thanks!

    Abraham

    Thursday, December 20, 2012 7:27 AM
  • Hi Abraham,

    My issue resolved once User profile serivce was configured. The farm where I was having this issue did not have the UPS configured - once I provisioned UPS (did not even had to import users) that the issue was resolved. Hope this helps!

    Good luck!!


    BlueSky2010
    Please help and appreciate others by using forum features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Sunday, December 23, 2012 2:27 AM
  • Hi Thanks for the valuable information. Issue resolved after UPS configuration.

    Regards!

    Monday, December 24, 2012 7:37 AM
  • Hi, I even faced the same issue. These are the steps which i followed in order to resolve this:

     1. In Central Admin->Application Management-> Manage Service Applications ->Checked whether the user profile service application is created--- It was created.

     2. In System Settings-> Manage Services on this server-> Checked if user profile service and user profile synchronization service are started-- It was also positive.

     3. In Application Management-> Manage web applications-> Clicked on the webapplication on which my site is running-> Clicked on Service Connections present in the ribbon.--- BOOM!!! The user profile service application was not associated with this webapplication. I checked it and then it Worked.

    Thanks. 

    Friday, June 5, 2015 10:03 AM
  • User profile service already running. Checked Target audience in List also. But still not working. Any other solutions???

    Regards,
    Bijay
    SharePoint MVP, India
    Twitter | Facebook | LinkedIn
    EnjoySharePoint.com | OnlySharePoint2013.com

    Friday, July 3, 2015 8:32 AM
  • Hello, I have the same problems.

    Any suggestion?

    Regards

    Andres

    Monday, September 10, 2018 9:36 PM