locked
Can't switch Apps

    Question

  • I've dual booted my Win7 PC with the Win8 Dev Preview, and it's all installed and activated and seems to be working fine. The only problem is that I can't switch apps by dragging/clicking on the left hand side of the screen. Alt-Tab and Win-Tab work fine, they switch apps with no problems, but the aforementioned method for switching apps doesn't work, which is disappointing, because I really like it. I've re-installed Windows 8, and I'm still having the same problem. Previously I have installed Win8 in a Virtualbox virtual machine, and have had no problems at all, the left side dragging/clicking app switching was working fine. Any help will be much appreciated, thanks.
    • Edited by lamboman007 Sunday, September 18, 2011 7:53 PM
    Saturday, September 17, 2011 9:37 PM

Answers

All replies

  • Hey there,

    What resolution is the screen set at? What if you try with different resolutions? Does that fix the problem?

    Regards,

    Bobby

    Sunday, September 18, 2011 10:14 PM
    Answerer
  • The screen is set at 1280x1024. I tried setting it to 1024x768 and it still didn't work, then switched it back and still nothing. In my virtual machine it worked fine at both those resolutions. I'm starting to think it might be a windows process that isn't starting when the PC boots.
    Monday, September 19, 2011 11:20 PM
  • hi, I have the same problem, my resolution is 1360*768...any idea?
    Thursday, September 22, 2011 12:01 PM
  • Something I've just discovered, whenever I have the Task Manager open and selected as the active window, the app switching works just fine...weird.
    Friday, September 23, 2011 8:53 AM
  • same here, maybe it's a bug.. hope they will fix it with updates..
    Friday, September 23, 2011 10:51 AM
  • Few thing you need to make sure.

    1. Display should be above 1024x768
    2. UAC should not be disabled
    3. Make sure you have display drivers are installed properly
    4. Some display vendors like ATI has tweeted that you'll be getting driver updates through Windows Update, so make sure you apply all the Windows update.

    Microsoft MVP - Windows Expert (IT Pro)

    • Edited by CaptainMVP Friday, September 23, 2011 12:32 PM
    Friday, September 23, 2011 12:32 PM
  • 1. My Display  is at 1280x1024

    2. UAC is not disabled

    3. I installed the NVidia 285.27 Beta drivers to try and fix the problem, but it didn't work. Hopefully it is just a bug with the graphics drivers and it'll get fixed soon :) Also, my GPU is a 9600GT.

    Saturday, September 24, 2011 12:42 AM
  • i've installed new vga driver from windows update....nothing happend,still unable to snap apps.

    rel : 1360*768

    vga: HD4670

    Saturday, September 24, 2011 6:05 PM
  • Force snap:

    http://www.askvg.com/how-to-force-enable-windows-8-snap-feature-in-low-screen-resolutions/


    "A programmer is just a tool which converts caffeine into code"

    Saturday, September 24, 2011 6:22 PM
  • exactly the same problem here :S 
    Tuesday, September 27, 2011 3:11 PM
  • Thanks for all of the detailed bug reports, we're trying to track down what might be going on here.

     

    To summarize, several of you are unable to navigate through the back-stack using the left edge of the screen unless task manager is the active window (but alt-tab works)

    Have any of you with this problem used the registry key trick to enable the old start menu?

     

    Wednesday, September 28, 2011 5:22 PM
  • No sir i didn't used any registry trick and i really don't know why i get this issue while my pc it ran win8 rather well without any issues, i have installed it from September 15 with all device drivers and and updates but still i'm facing now that issue and even after doing re-format of win8, so i think it might be a bug and hope you can fix as soon :)
    Thursday, September 29, 2011 3:19 PM
  • Nope, I haven't touched the registry at all. I quite like the new Start screen :)

    Monday, October 03, 2011 12:35 AM
  • Hey, it's working now! :D

    I just downloaded the latest updates and it's working all fine now.

    Monday, October 03, 2011 1:12 AM
  • @lamboman007 really ?
    Monday, October 03, 2011 9:10 PM
  • @lamboman007 what kind of updates have you installed ? because in my windows update it says "your pc is up to date!"

    Monday, October 03, 2011 9:18 PM
  • Just checked my update history, turns out that the update was a Definition Update for Windows Defender. So, I don't think it was the update that fixed it then. I seriously have no idea why it's working now, nothing else has changed... :/
    Monday, October 03, 2011 10:22 PM
  • Have had this same error. I you have some Metro apps opened try ending them with Task Manager and then attempt to snap either to the left or to the right of the screen. Try waiting until the window snaps. Does NOT work for me perfectly. Sometimes I can't snap windows as well.
    Well this is the world we live in And these are the hands we're given...
    Tuesday, October 04, 2011 10:18 AM
  • oh God i tried everything and still can't get to work left edge of the screen to swich apps with mouse, i tried re-format of win8 but still no helps :(:(:( i really don't know why i get this issue while it ran rather well :S

    Tuesday, October 04, 2011 11:15 AM
  • Are you using 64-bit OS flavor?
    Well this is the world we live in And these are the hands we're given...
    Tuesday, October 04, 2011 2:09 PM
  • yes im using Windows Developer Preview X64 + Developer Tools with Windows 7 x64 dual-boot
    Tuesday, October 04, 2011 3:53 PM
  • Seems like 64-bit version has glitches with snap.
    Well this is the world we live in And these are the hands we're given...
    Wednesday, October 05, 2011 10:22 AM
  • Hmm you're right, im going to install 32bit version but do i need first to install Windows 7 64Bbit or Windows 8 32bit for dual booting ?

    Wednesday, October 05, 2011 10:35 AM
  • Hey guys, finally i fixed the problem with dragging/switching apps on the left side of the screen, so i just changed my "usb mouse" to an "non usb mouse" and problem it's gonne :)
    Thursday, October 06, 2011 4:30 PM
  • hi mates!

    finally I got it!

    just install and run snap enabler app and restart one time...

    I don't know how exactly that is activated cause without restart that app won't work!


    Sunday, October 09, 2011 9:44 AM