none
Problem with USB Controller RRS feed

  • Question

  • Hi!

    I just got my Kinect v2 and hooked it up to my Lenovo G50-70 with Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz, 6GB RAM and Windows 10.  I ran the Kinect v2 Configuration Verifier  and everything was good except the USB Controller Test get the infamous result “Supported USB 3.0 port detected with unknown bandwidth. Kinect may or may not be compatible with your hardware." I can not really understand what it is that does not work, my hardware seems compatible with Microsoft specifications. Therefore:

    First – How do you check  that no other devices are sharing bandwidth with that connection?

    Second – Assuming my bandwidth is being shared, how can I turn off the devices that are connected to the USB3 Host Controller so that I just have the one USB3 port active to use with the Kinect.

     Thanks everyone for your help and sorry for my english (I'm an italian computer science student)!

    Giorgia

    Wednesday, August 2, 2017 1:49 PM

All replies

  • Hi, a couple things.

    1. Make sure your Windows is updated.

    2. Make sure you graphics driver is updated.

    3. Open device manager and see if the Kinect is connected and the driver has been installed.  If it is not installed you will see an ! and you will need to right click and update driver.

    These are the basic things to look at.

    David

    Wednesday, August 2, 2017 7:32 PM
  • Thanks for your reply David, unfortunately I did all the updates and the problem persists. For my degree thesis I should develop a Kinect application and I'm really tight with deadlines and this problem does not allow me to work. Do you think buying an external USB3 chipset could help me solve the problem?

    Giorgia

    Thursday, August 3, 2017 9:09 AM
  • You forgot to mention the most essential point in your initial post: What does the last point of Kinect v2 Configuration Verifier "Verify Kinect Depth and Color Streams" report?

    If you see a stable 30 fps then you shouldn't care about USB Controller verification step - I have seen that verification step result "in green" only a few times in my life across different hw configurations.

    It is not possible to add additional USB controller to your notebook.

    Thursday, August 3, 2017 10:59 AM
  • Hi Jan, thanks for the information; all other points are green in my case. So you say that it's not a problem that the usb controller is recognized as incompatible? If so, I would not be able to explain why when I run the examples provided in SDK, the gestures are not recognized and it would be a good question for another thread, but at least I can look for a solution elsewhere.

    Giorgia

    Thursday, August 3, 2017 12:36 PM