none
Windows Layout Not Working for Floating Windows

    Question

  • In VS Community 2015, I set the position of document windows as floating outside the VS frame then save the layout.  But when I restart VS and apply the saved layout, the windows are opened as docked inside the frame.  Nothing I've found in the documentation says that this shouldn't work.

    Suggestions?

    Monday, November 9, 2015 11:16 PM

All replies

  • Hi SezMe,

    I tested this issue on my visual studio 2015 community, and I set the window layout, when I restart the VS, the window is still layout, it doesn't dock inside the frame.

    So I doubt that it is related to your visual studio IDE.

    Please open Windows Explorer, and navigate to  <Visual Studio Installation Path>\Common7\IDE (by default is C:\Program Files or Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE), and run the following commands:

    a.devenv.exe /resetsettings, it will restore Visual Studio default settings. Optionally resets the settings to the specified .vssettings file.

    b.devenv.exe /resetuserdata, it will take a couple of minutes to run as Visual Studio cleans up and sets itself back to its original state. You may open Task Manager at this point to check whether the devenv.exe process is still running. After it has completed running, you can restart Visual Studio.

    c. Devenv.exe /SafeMode, This can eliminate the possibility that third party Add-ins or packages are causing problems. Thus ensuring stable execution.

    d. Devenv.exe /ResetSkipPkgs, it will clear all SkipLoading tags that have been added to VSPackages by users who want to avoid loading problem VSPackages.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Tuesday, November 10, 2015 7:23 AM
    Moderator
  • Sadly, this not only didn't work, I now cannot run VS at all.  When I start it up, I get a screen that says my 30 trial has expired and do I want to buy it.  Then it pops up a screen that says:

        Sorry, we ran into a problem

        SP324099: Could not complete the operation.

    Please address this ASAP.  Do I have to uninstall and redo the installation?


    • Edited by SezMe Wednesday, November 11, 2015 12:45 AM image didn't work
    Wednesday, November 11, 2015 12:43 AM
  • Hi SezMe,

    Please make sure that you have IE 11 installed and then sign in with your microsoft account.

    If you couldn't sign in, I think you need to uninstall your visual studio and then reinstall it. Please use /uninstall /force to uninstall it:

    1.Download the setup application you used to originally install Visual Studio 2015. If you installed from media, please insert that media.
    2.Open a command prompt.
      a.Click Run on the Start menu (Start + R).
      b.Type cmd and press OK (Enter).
    3.Type in the full path to the setup application and pass the following command line switches: /uninstall /force
      Example: D:\vs_community.exe /uninstall /force

    4.Click the Uninstall button and follow the prompts.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Wednesday, November 11, 2015 7:56 AM
    Moderator
  • I have IE11 installed.  I read all the entries on stackoverflow but none of the suggestions applied to my case.

    But, an update:  Later, I was able to restart VS.  It didn't give any of the warning messages and seems to be working OK.  Of course, I had to reset all my options and recreate my custom toolbar.

    Well, there is one problem: My custom layout is STILL not working.

    Wednesday, November 11, 2015 10:25 PM
  • Hi SezMe,

    Please go to Window -> Reset Window Layout, to see if it helps.

    If the above doesn't help, please refer to this page to see if it helps: https://msdn.microsoft.com/en-us/library/4k7zyeba.aspx?f=255&MSPPError=-2147217396

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Thursday, November 12, 2015 8:21 AM
    Moderator
  • Reset didn't do anything.

    I've read that topic already but I'll go over it again, taking more time to make sure I'm not missing anything.

    Suppose I get my custom layout to work.  Is there a command line argument when starting VS to tell it to use the indicated custom layout?

    Thursday, November 12, 2015 9:00 AM
  • Hi SezMe,

    >> Is there a command line argument when starting VS to tell it to use the indicated custom layout?

    I suggest you could go to Tools -> Import and Export Settings, and then export settings.

    And after launching the visual studio, import the settings to see if it helps.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Friday, November 13, 2015 8:38 AM
    Moderator