none
error installing.. pls help.. RRS feed

  • General discussion

  • [06/10/09,11:04:00] Microsoft .NET Framework 2.0a: [2] Failed to fetch setup file in CBaseComponent::PreInstall()
    [06/10/09,11:04:00] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with

    HRESULT -2147467260.
    [06/10/09,11:04:00] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
    [06/10/09,11:04:00] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL

    piActionResults
    [06/10/09,11:04:00] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
    [06/10/09,11:04:00] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in

    ISetupManager::RunInstallFromThread()
    [06/10/09,11:04:00] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
    [06/10/09,11:04:00] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
    [06/10/09,11:04:01] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.
    [06/10/09,11:04:01] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 was not attempted to be installed.
    [06/10/09,11:04:01] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' was not attempted to be installed.
    [06/10/09,12:40:42] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework

    3.5 'package'. MSI returned error code 1603

    EventType : visualstudio8setup     P1 : 35101    
    P2 : 3.5.30729.01_orcas_x86_net     P3 : mc     P4 : inst     P5 : f    
    P6 : registerproduct     P7 : 0     P8 : 1603     P9 : -    
    P10 : gencomp301_{12cd
    • Changed type YiChun Chen Wednesday, June 17, 2009 3:51 AM Do not follow up
    Wednesday, June 10, 2009 4:47 AM

All replies

  • Hi Wawawi,

    More clarification with you. What's the OS? Do you want to install Visual Studio 2008?

    From the log files, it seems that .NET Framework 3.5 cannot be installed.
    Could you please try using collect tool to collect the log files of .NET Framework 3.5 full package from your "%temp%" folder?
    http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx

    You can upload your log files to SkyDrive and post the link back here.

    Steps:
    - Try to clean your "%temp%" folder
    - Install .NET Framework 3.5 full package separately
    - Collect the logs from "%temp%" folder

    Thanks

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, June 11, 2009 9:11 AM
  • Hi Wawawi,

    We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Thank you!
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, June 17, 2009 3:50 AM