locked
Android Player Displays OpenGL Error RRS feed

  • Question

  • User79844 posted

    Using Xamarin Android Player version 0.0.25 on MacBook Pro running OS X 10.9.5.

    Running either one of the currently available Nexus virtual machines displays the following error in a popup window:

    "OpenGL server is unreachable. Please check that Xamarin Android Player is allowed through your firewall on public networks."

    Clicking the OK button on the popup will hide the Android Player virtual machine window, but the virtual machine itself will continue to run in the background until I click the Stop button on the Devices list.

    The OS X firewall is turned off.

    When watching the preview window in VirtualBox 4.3 the virtual machine continues to boot and eventually will display the Android home screen within the VirtualBox preview window.

    I have tried uninstalling both the Android Player and VirtualBox, but am still encountering the same problem.

    Is there anything else I should try?

    Thursday, October 16, 2014 8:38 PM

All replies

  • User80630 posted

    I have de same problem in VS2013, i have no idea what to do... =(

    Sunday, October 19, 2014 6:36 AM
  • User35 posted

    You'll get that error if you try to change the network settings for the Player VM. You have to leave those alone.

    Monday, October 20, 2014 1:51 PM
  • User79844 posted

    Genymotion automatically changes the network settings in the VM for use with it's Android VM. I've uninstalled Genymotion, Xamarin Android, and VirtualBox (using the VB complete uninstall script). Then reinstalled Xamarin Android alone (which automatically installs VirtualBox).

    I'm still seeing the same problem. Perhaps there are files on OS X that need to be deleted in order for a complete uninstall of Xamarin Android Player? Any help would be greatly appreciated.

    Monday, October 20, 2014 2:43 PM
  • User35 posted

    Try this to uninstall the Xamarin Android Player:

    1. Uninstall previous versions of Xamarin Android Player
    2. Open up VirtualBox and remove all of the Xamarin Android Player devices, choose to delete files.
    3. Open the VirtualBox Virtual Media Manager and ensure there are no data.vdi, system.vdi or sdcard.vdi files remaining. If there are, release and remove them.
    4. Delete \Library\XAP

    Then run the installer for the Xamarin Android Player.

    Just curious, did you first install the Xamarin Android Player and then Genymotion? I have both installed and not seeing these issues.

    Tuesday, October 21, 2014 2:00 PM
  • User79844 posted

    Genymotion was installed first, by someone from Xamarin at the Evolve 2014 conference.

    So I've followed your instructions and am still getting the same results: an OpenGL error. I have attached the Log folder from /Library/XAP. Could someone take a look at see if there's something obvious that's causing this problem? The Mac I'm using is set up as an enterprise client, so that might have something to do with it. But unless I know what's the problem and how to overcome it this problem will be a non-starter for us, at least for XAP. Genymotion does work so we do have a way to debug Android apps for now.

    Tuesday, October 21, 2014 3:06 PM
  • User80630 posted

    I have the same issue and i dont know what to do, pls help!

    Monday, October 27, 2014 4:12 PM
  • User40911 posted

    I saw this error the first time I tried to run one of the VMs. I do not have Genymotion installed and I haven't touched any of the network settings.

    Thursday, October 30, 2014 2:40 PM
  • User79844 posted

    XAP is working on my Macbook now, and I've found a way to reproduce the error in my environment.

    Following is a list of scenarios where XAP works or does not work. I am running VMWare Fusion 6.0.5. The company VPN connects via Cisco AnyConnect Secure Mobility Client v3.1.05152.

    • Reboot, immediately open XAP: WORKS
    • Reboot, then start Fusion, then open XAP: WORKS
    • Reboot, then start Fusion, then connect VPN, then open XAP: DOES NOT WORK
    • Reboot, then start Fusion, then open XAP, then connect VPN, then open XAP: WORKS
    • Reboot, then start Fusion, then connect VPN, then close Fusion and disconnect from the VPN, then open XAP: WORKS
    • Reboot, then start Fusion, then connect VPN, then close Fusion, then open XAP: DOES NOT WORK

    The VPN requires that Fusion be running before it can connect.

    These scenarios indicate that if we open XAP immediately after reboot then it will work fine with VMWare Fusion and the company VPN. XAP will continue to work through multiple restarts of the XAP app and restarts of Fusion. However, if we open Fusion and connect to the VPN before opening XAP, XAP will display the OpenGL error.

    Thursday, October 30, 2014 7:45 PM
  • User80171 posted

    I get the same problem with Windows 8.1. VirtualBox add a network connection in each time that it starts, and finally get: "OpenGL server is unreachable. Please check that Xamarin Android Player is allowed through your firewall on public networks."

    Thursday, November 6, 2014 8:09 AM
  • User25759 posted

    Can you double check your firewall settings? Maybe also try to change the OpenGL setting to any: http://screencast.com/t/kAGfX68ksPMs

    Friday, November 14, 2014 11:24 PM
  • User87944 posted

    Hi, someone solve this problem. I have the same issue, I disable firewall but I still have same problem. OpenGL server is unreachable. Please check that Xamarin Android Player is allowed through your firewall on public networks.

    Friday, December 5, 2014 2:26 AM
  • User26374 posted

    I have the same problem on OSX after connecting and disconnecting to VPN. On VirtualBox settings Network is Host Only

    Tuesday, December 16, 2014 7:33 PM
  • User94662 posted

    Same issue with my XAP on OSX. the error appears since I changed the IP addresses of the parallels "host-only" and "shared networks". Spent about two hours trying to recover from the issue, am postponing using Xamarin.Android for the moment.

    Tuesday, December 23, 2014 6:43 AM
  • User94662 posted

    Resolved the OpenGL issue by deleting and re-creating the virtualbox "host-only network adapter" (vboxnet0) in virtual box preferences.

    Tuesday, December 23, 2014 7:44 AM
  • User9505 posted

    I haven't been able to fix this issue by playing the with adapters (recreating, creating a new one, etc). Once I use VPN, the Android Player fails to work. Deleting the device and recreating it doesn't even work. The only way I've been able to get it to work is (I'm on a Mac):

    1. Remove both VirtualBox and Xamarin Android Player apps
    2. Reopen Xamarin Studio so it detects that Android Player has been uninstalled. Now close it.
    3. Under the user directory, remove the VirtualBox VMs folder
    4. Under /Library, remove the XAP folder.
    5. Restart computer
    6. Reinstall Android Player

    ...so yeah, a better workaround or fix would be much desired.

    Monday, December 29, 2014 6:54 PM
  • User9505 posted

    Is there any update on this?

    Tuesday, January 20, 2015 9:41 PM
  • User51669 posted

    Look here ... it depends on your driver https://bigred2162.wordpress.com/2013/07/06/finally-a-fix-for-windows-8-opengl-error/

    I did it and it worked like a charm ;)

    Thursday, January 29, 2015 7:47 PM
  • User9505 posted

    Running on a Mac. Any update?

    Wednesday, February 4, 2015 3:14 AM
  • User68194 posted

    RossBender, I had this issue on Mac. My firewall setting was "Block all incoming connections". I unchecked it and then started the player. The player gave me a popup whether or not to allow the app to go through firewall. I clicked Allow and it worked. If this doesn't work you though, then you can explicitly add an exception for Xamarin Android Player.app. Hopefully this works for you.

    Wednesday, April 1, 2015 7:20 PM
  • User119937 posted

    Any update on this? I have "starter", I installed it yesterday and it worked properly, but today it is showing me that error, I hope this will be fixed soon, since I am unable to run genymotion either, so I need it.

    Thursday, April 9, 2015 11:54 PM
  • User87283 posted

    [Solved]. McAfee Antivirus was blocking the firewall. I just turned off the firewall protection in McAfee Antivirus for 30 minutes (the duration as much you want), and android player started working perfectly.

    Friday, April 17, 2015 11:53 AM
  • User125913 posted

    Had this problem on mac with Cisco AnyConnect VPN. Worked by starting the Android Player before the VPN as suggested by CurtisGray.0467 above. Would be nice to figure out what exactly the VPN is messing up for this to occur.

    Thursday, May 7, 2015 3:33 PM
  • User21936 posted

    I don't think it is related but posting here as it is an OpenGl error that is affecting Nexus 4 devices, including the Nexus 4 in XAP. https://code.google.com/p/android/issues/detail?id=61868

    This error happens occasionally every few app launches according to one report.

    Thursday, May 7, 2015 10:31 PM
  • User77747 posted

    For those having issues with Cisco AnyConnect, I have had success doing the following:

    1. Launch your Xamarin Android Player device before opening Cisco AnyConnect.
    2. Open Cisco AnyConnect and connect to the VPN.
    3. Use ipfw to delete the "deny ip from any to any" rule. (Just Google it and find instructions. For Yosemite and above you'll need to get ipfw from another machine since it's no longer included by default.)
    4. Now close Xamarin Android Player and re-open it. Somehow everything works again.

    You have to perform these steps every time.

    Note: I used to not have to do step 4, but that now seems necessary.

    Friday, June 5, 2015 10:02 PM
  • User122628 posted

    No Solution Yet..... Why Xamarin Team doesnt do anything about it, this is Xamarin Android player bug , and as far as i know this is exist from first release of Xamarin Android player .

    Tuesday, November 17, 2015 9:19 AM
  • User9505 posted

    I still have issues with this and believe it is related to using the Cisco VPN client. Any possibility/ETA on a fix?

    Saturday, November 28, 2015 4:41 AM
  • User183287 posted

    @yasiralijaved said: [Solved]. McAfee Antivirus was blocking the firewall. I just turned off the firewall protection in McAfee Antivirus for 30 minutes (the duration as much you want), and android player started working perfectly.

    Thanks !!!!!!!!! It works.

    Saturday, December 26, 2015 7:22 PM
  • User198206 posted

    Genymotion runs fine, Xamarin Android Player returns the OpenGL network error. I'm running on my work development machine. We have confirmed firewall settings. We can watch our firewall log allow Xamarin Android Player communictaion. Hyper-v is not installed. We have confirmed OpenGL is supported by the integrated graphics card. I still receive the error. Very disappointed that Xamarin creates an app that has so many constraints and doesn't provide any information why it cannot run other than a "cannot be reached error." Many work machines are locked-down like Hogwarts and Xamarin's approach needs to be flexible if they're going to offer this solution.

    Thursday, March 3, 2016 3:40 PM
  • User206338 posted

    firewall -> advanced -> inbound -> xamrain player openGL -> protocols and ports -> make it TCP / ALL

    Tuesday, April 12, 2016 5:02 AM
  • User221181 posted

    I fixed this by allowing Android player through firewall. Getting weary of all these issues .. hopefully I can get back to developing and stop messing with core system settings that could render my dev machine unusable at any time.

    Friday, July 29, 2016 12:46 AM