locked
Failed to execute request because the App-Domain could not be created. Error: 0x80070005 Access is denied. RRS feed

  • Question

  • User-9149483 posted

    Please could someone help me configure a test website on my server?

    I've been working on a website in Visual Web Developer 2005 Express Edition, & now wish to 'copy' this site to our live server, as I need to test something that will only work there. I say 'copy', as I've just discovered that the Express Edition doesn't 'publish', but I don't think this matters.

    I've had a load of fun trying to get this working, with lots of issues I've resolved by scouring sites such as this. However, I can't seem to find anything useful on this latest problem.

    So I've copied the files across, installed the .Net 2.0 Framework, installed it in IIS (%windir%\Microsoft.NET\Framework\vxxxxxx\aspnet_regiis.exe -i), & all these steps seemed to take me closer to it working, as the various error messages have changed many times.

    One step I tried didn't give the expected result - I ran this:
    regsvr32 %windir%\Microsoft.NET\Framework\vxxxxxx\aspnet_isapi.dll

    but got an error message saying:
    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll was loaded, but the DllRegisterServer entry point was not found.

    This file can not be registered.

    Does that matter? It sounds important.

    Anyway, whether that is the problem or not, when I try to view the website, I get the following error:

    ________________________________________________________________________________
    Server Application Unavailable

    The web application you are attempting to access on this web server is currently unavailable.  Please hit the "Refresh" button in your web browser to retry your request.

    Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.
    ________________________________________________________________________________

    Interestingly enough, in the Event Log, I see the following:

    Warning Event
    Failed to initialize the AppDomain:/LM/W3SVC/223085046/Root

    Exception: System.IO.FileLoadException

    Message: Could not load file or assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. Access is denied.

    StackTrace: at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)

    at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

    at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

    at System.Activator.CreateInstance(String assemblyName, String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, Evidence securityInfo, StackCrawlMark& stackMark)

    at System.Activator.CreateInstance(String assemblyName, String typeName)

    at System.AppDomain.CreateInstance(String assemblyName, String typeName)

    at System.AppDomain.CreateInstance(String assemblyName, String typeName)

    at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironment(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)

    at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironmentAndReportErrors(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Error Event
    Failed to execute request because the App-Domain could not be created. Error: 0x80070005 Access is denied.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Of course, when you click on the Help & Support Centre link, it tells you there is no further information available.

    I think it's something to do with AppDomain, but don't know what that is, so I don't know how to proceed.

    Can anyone help?

    Thanks.

    Monday, February 6, 2006 2:33 PM

All replies

  • User-9149483 posted

    I had to give the IIS_WPG group (which contains ASPNET, IWAM_MachineName, LOCAL SERVICE, NETWORK SERVICE & SYSTEM) read/write access to our web root directory & everything beneath.

    Thanks.

    Tuesday, February 7, 2006 1:29 PM
  • User-1250502022 posted

    I didnt have this problem in Windows Server 2003 SP1 Enterprise Edition. The problem came up when we were trying to test in Windows Server 2003 R2 SP1 Standard Edition. After giving permissions to IIS_WPG group it started working.

     Thanks

    Wednesday, November 22, 2006 1:01 PM
  • User-871403846 posted

     For those finding this from a google search of your error (like myself)

    adding the IIS_WPG read/write access also worked for me, but either make sure that all the subfolders inheret their parent dir  permisions settings or apply the permissions to EVERYTHING inetpub and below

     (at least thats what i had to do, just applied IIS_WPg to everything, so i couldnt actually tell you what is actually needed and what acually isnt.)
     

    Tuesday, May 22, 2007 3:05 PM
  • User954022740 posted

     For those finding this from a google search of your error (like myself)

    adding the IIS_WPG read/write access also worked for me, but either make sure that all the subfolders inheret their parent dir  permisions settings or apply the permissions to EVERYTHING inetpub and below

     (at least thats what i had to do, just applied IIS_WPg to everything, so i couldnt actually tell you what is actually needed and what acually isnt.)
     

    After finding your comment I went to IIS and right clicked on my website, clicked permissions, then added IIS_WPG from the local server (we also have a IIS_WPG domain group).  I only left the read box checked and it solved the problem.

    Friday, June 29, 2007 12:02 PM
  • User-1833483127 posted

    This solved it.. Thanks Paul !!!

    Thursday, July 26, 2007 2:06 PM
  • User320340853 posted

    Hi

    I have followed an example in a book called IIS 6.0 the Complete Reference, although very good the exmaple they give for setting up an Anonymous group with the IUSR_MACHINENAME account doesnt quite work propoerly and you get this error as above.

    If your running ASP.NET Apps then you definitely need to remove all inheriting permissions, and add the IIS_WPG group to your site. However my query is:

    Do you need to assign Write access to this group on the root of your website?

    Regards
    Anthony

    Friday, November 23, 2007 6:01 AM
  • User320222932 posted

    Thanks it worked for me..adding IIS_WPG on top of inetpub folder.

     

    Wednesday, December 5, 2007 4:50 PM
  • User-931283679 posted

    Excellent comment -- this fixed it for me, too (using Windows Server 2003 on a 64-bit Turion processor). Thanks bfrancis!

    Tuesday, December 11, 2007 6:39 PM
  • User1205779922 posted

    I also needed to change the user to IWAN_MACHINE in the aplication pool

    Monday, December 31, 2007 6:49 AM
  • User1031775717 posted

    For me, I had to register the asp.net in IIS

     

    See http://kbase.gfi.com/showarticle.asp?id=KBID002202 

    Monday, February 18, 2008 10:00 PM
  • User699870353 posted

    Added IIS_WPG to the permissions on just the one website i was running 2.0 on and it worked.  Thanks!

    Wednesday, February 27, 2008 8:37 PM
  • User-175177222 posted

    How can i add IIS_WPG to the permission.. I have windows xp Professional installed..

     

    any help will be appreciated..

     

    Karen

    Wednesday, March 19, 2008 1:18 PM
  • User-1487448002 posted

     This problem is everywhere. I have the same issue.

    We got stuck for 2 days, till I find this thread.

    For me, I got it working when I create a separate Application Pool for that application.

    and change the Identity to point to Local machine instead of network service....

    Weird...

    Dark Lord, Sith

     

    Wednesday, June 18, 2008 2:02 AM
  • User-175177222 posted

    it worked fine for me after i installed Ajax..

    Wednesday, June 18, 2008 9:12 AM
  • User12518661 posted

    Just do a ASPNET_REGIIS -i . This will fix ur issue. No need o give permission and all.

    Wednesday, July 23, 2008 2:34 PM
  • User674654302 posted

    Added IIS_WPG group and it worked..hooray!! ALso make sure if you have different versions of the .net framework, you create separate Application Pools, as mentioned earlier

    [:D]

    Friday, August 29, 2008 5:20 AM
  • User-464668683 posted

    Failed to access IIS metabase.

    For information on modifying metabase permissions,  please see http://support.microsoft.com/?kbid=267904

    Download the Metaacl.exe package

     

    WindowXP    [version 5.1.2600]    SP2                      ASP.NET version 2.0.50727

    Note If you are using ASP.Net 2.0 and you must grant metabase permissions to a Windows user account, do not use the MetaAcl tool. Instead, run the ASP.NET IIS Registration Tool command together with the -ga option. For example, the following command grants the Windows user account <WindowsUserAccount> permissions to the IIS metabase:

    aspnet_regiis -ga <WindowsUserAccount>
    Friday, October 17, 2008 12:02 AM
  • User-1808907414 posted

    Thanks for the post - I've been trying to get this to work for the last couple of days!

    Giving IIS_WPG 'read & exec', 'list' and 'read' permissions on the wwwroot folder fixed it [:)]

    Shaun.

     

    Tuesday, December 23, 2008 11:49 AM
  • User404296453 posted

     FYI, I also just added read & execute, list and read permissions and this solved the issue. Thank you and thank google for listing this thread as the number one result.

    Thursday, April 2, 2009 12:02 PM
  • User660846665 posted
    switching to local machine worked for me too - thanks for the post!
    Thursday, April 9, 2009 5:30 PM
  • User852875298 posted
    "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\ASPNET_REGIIS -i" resolves my issue. Thanks very much. John
    Friday, May 8, 2009 2:39 PM
  • User-1532916674 posted

    I had to give the IIS_WPG group (which contains ASPNET, IWAM_MachineName, LOCAL SERVICE, NETWORK SERVICE & SYSTEM) read/write access to our web root directory & everything beneath.

    Thanks.

    i have adding the IIS_WPG, iusr, iwam to the IIS website and the application.  nothing is working for me, i also added the same permission to local folders on the machines and that isnt working either for me. i am still getting the same error.


    is there any other advice

    Tuesday, June 30, 2009 2:02 PM
  • User1920001140 posted

    This may sound stupid but I can't find a way to get this solution to work for me. I can't find IIS_WPG or where to give permissions. I'm just tryin to get this thing setup for local testing and it's becoming a huge pain in the ass. 

    Wednesday, December 2, 2009 5:50 PM
  • User1031775717 posted

    Maybe .net didn't register properly. Try using iisreg with the -i option.

    http://msdn.microsoft.com/en-us/library/k6h9cz8h%28VS.80%29.aspx

    Wednesday, December 2, 2009 6:40 PM
  • User1920001140 posted

    I did that first and went to use regsvr32 to register aspnet_isapi.dll and everytime i get the message that it loaded but the entry-point DllRegisterServer was not found. I've been searching and the solutions people have presented are that IIS_WPG has to have permission to read/write/execute in the site folder. I was trying to find just how exactly to do that and haven't had any success.

    Thursday, December 3, 2009 8:49 AM
  • User-1648329700 posted

    Open IIS, right-click on your website, select PERMISSIONS, click ADD in new window.  In the 'From this location' box, make sure the server is selected.  If not, click the Locations... button and scroll all the way to the top to select the server/machine of your website.  Click OK to get to the 'Select Users, Computers, or Groups' screen.  Enter IIS_WPG in the 'Enter the object names to select' section.  Click OK.  Highlight the IIS_WPG user that has been added, and give appropriate permissions.  Click OK & test.

    Thursday, December 3, 2009 9:12 AM
  • User1920001140 posted

    That's the problem, Edit Permissions just opens the folder properties window and there is no security tab or anything. If I failed to mention this before I'm using Vista Home Premium 64bit. 

    Thursday, December 3, 2009 9:21 AM
  • User1223447501 posted

    Thank you Paul, its save my day!!!

     

     

    Tuesday, May 4, 2010 2:06 PM
  • User2050496404 posted

    thanks ... it worked!!

    Wednesday, July 7, 2010 8:15 AM
  • User-177021704 posted

    was for me just .net did a repair on 3.5sp1 and also re registered the IIS extensions aspnet_regiis -i


    done and working.


    Tuesday, August 10, 2010 10:46 PM
  • User-1797724146 posted

    For us the solution had nothing to do with permissions... There was a configuration file for the worker process (C:\WINDOWS\Inetsvr\w3wp.exe.config) that defined Framework 1.1 of all things as the runtime to use.  There was nothing readily apparent that pointed us to this file, but if you've read this far down the thread and see the "app-domain" Event error described above, you might check for and delete w3wp.exe.config.

    Friday, October 15, 2010 10:24 AM