none
SharePoint 2013 not sending welcome email RRS feed

  • Question

  • I am facing rather strange issue . My farm sends alert notification and all to the user based upon their email id. But when a user is added to the site collection, even if the check box is checked , it does not send out an email notification. Is there something i need to do make this feature work?

    Adit

    Friday, July 11, 2014 5:56 PM

Answers

  • I figured it out. Our servers were moved from one domain to other. The new domain for some reason is not resolving smtp gateway through its name. When i used VIP, it started working. 

    Thank you all for the suggestions. 


    Adit

    • Proposed as answer by Alex Brassington Tuesday, July 15, 2014 3:49 PM
    • Marked as answer by Lindali Sunday, July 20, 2014 9:30 AM
    Tuesday, July 15, 2014 3:44 PM

All replies

  • Hi, 

    I did tried to disable globally once. which is completely opposite but may be helpful.

    edit the _layouts/aclinv.aspx file 

    Here is the steps:

    1.       Navigate to C:\Program Files\Common Files\Microsoft Shared\web server extensions\15\TEMPLATE\LAYOUTS folder.

    2.       Find aclinv.aspx file.

    3.       [Important!]Backup the aclinv.aspx file with aclinv.aspx.bak or other file name you specific.

    4.       Edit the aclinv.aspx file with Notepad or other editing tool.

    5.       Search for “chkSendEmail”, you should see property Checked="True" under it.

    True = email will be send out 

    False = email disabled

    Hope that helpful.

    Thanks,

    Parth


    Thanks and Regards, Parth

    Friday, July 11, 2014 7:56 PM
  • It is set to true. Still it is not sending outgoing emails. I am confused if it can send alerts mails, why is it not able to send the welcome email?

    Adit

    Monday, July 14, 2014 4:36 PM
  • Are you sure it's not sending emails? They can easily get classed as junk/spam by filters.
    Monday, July 14, 2014 8:23 PM
  • Nope , i checked everything. Is there something that needs to be done in EXchange side? It works for both 2010 envrionment but not working for any of the 2013 environments.

    Adit

    Tuesday, July 15, 2014 3:46 AM
  • Hi

    Each Web Application has an email outgoing settings defined in SharePoint Central Admin.

    Please go to Central Admin -> Application Management

    Select the web application for your Site Collection. Go to General Settings -> Email Settings

    Verify if Outbound SMTP Server and From address is defined.

    Amit

    Tuesday, July 15, 2014 4:57 AM
  • Hello

    Are you adding your active directory useror an active directory group to the SharePoint group ?

    because if you add an AD group, you'll need to have an e-mail set on the AD group


    Best regards, Christopher.
    Blog | Mail
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.
    Why mark as answer?

    Tuesday, July 15, 2014 6:19 AM
  • Do you get any emails from the system?

    There are various steps to setup outgoing email, sometimes you can get away without worrying about it, other times changes may be needed at Exchange.

    Tuesday, July 15, 2014 8:01 AM
  • Yes, i get alerts from the system for list and libraries. Any delete and update i get email. But only outgoing emails do not work. It works for 2010 environment. What needs to be done in exchange ?

    Adit

    Tuesday, July 15, 2014 1:45 PM
  • If it's sending some of the time then it's highly unlikely that you need to configure connections or so on in Exchange.

    Your best bet is to trace an email through Exchange's logs to prove that it was sent to the user.

    Tuesday, July 15, 2014 2:34 PM
  • I figured it out. Our servers were moved from one domain to other. The new domain for some reason is not resolving smtp gateway through its name. When i used VIP, it started working. 

    Thank you all for the suggestions. 


    Adit

    • Proposed as answer by Alex Brassington Tuesday, July 15, 2014 3:49 PM
    • Marked as answer by Lindali Sunday, July 20, 2014 9:30 AM
    Tuesday, July 15, 2014 3:44 PM