locked
Cannot find Microsoft Word Application in DCOM RRS feed

  • Question

  • User232858574 posted

    Hi,

    I would like to config the Microsoft Word Application in DCOM for some function in my project.  So, I completely installed the Microsoft Office Professional Edition 2003 (32-bit version) in my server and go to the DCOM Config.  Actually, I can't find the object "Microsoft Word Application" but the "Microsoft Excel Application" is here.

    I don't know it should cause by the OS version or not.  The OS is using Microsoft Server 2003 R2 64-bit Edition with SP2.

    Do anyone have advise for me?

    Thanks.

    Tuesday, May 15, 2007 4:27 AM

All replies

  • User-2050417650 posted

    I have de same problem but I don´t now how to resolve it.  Did you find a solution to the problem?

     

    thanks

    Wednesday, May 23, 2007 4:56 AM
  • User232858574 posted

    Not fixed yet...I have tried to reinstall the Office or update its service pack, but it still not work...

    And you?

    Thursday, May 31, 2007 12:16 PM
  • User585475975 posted

    Hi, guys.

     It's Microsoft's tradition to add unnamed COM-components for it's Word Applications.

    If this problem actual for you still, you should be find Application Identifier in your Register (for example {08655947-3AD4-4A46-8381-29BD55FEEEE9} ).

    1. Find in way HKEY_CLASSES_ROOT->AppID your required winword.exe.

    2. See the AppId attribute (key).

    3. Using this AppId as key find DCOM component of Word with this value as name.

    PS You may use this AppId to search name of DCOM components in HKEY_CLASSES_ROOT->CLSID in general case (e.g. for Excel) (See key "By Default"). For Word case it's not necessary, because name of component equal it's AppID.

     

    Wednesday, June 20, 2007 4:11 AM
  • User2061032774 posted

    Блин! Ну, ты чувак гонимый! Ты в ГУИДах бы покопался! На крайняк в реестр залез бы! На те сцылку на Ворд 2k3 GUID {34A2653C-B92F-41EC-A8BE-A1004BB813AF}, тама найдёшь всё для счястья! Кстати, тебе зачем всё ента трЭба???

    Wednesday, June 20, 2007 4:39 AM
  • User-1795293456 posted

    hi!

    I'm having the same problem with DCOM and Word 2007,

    did you find a solution you can share?

    Friday, May 15, 2009 6:16 PM
  • User896656917 posted

    On 64 bit system with 32 bit Office try this:

    1. Start
    2. Run
    3. mmc -32
    4. File
    5. Add Remove Snap-in
    6. Component Services
    7. Add
    8. OK
    9. Console Root
    10. Component Services
    11. Computers
    12. My Computer
    13. DCOM Config
    14. Microsoft Excel Application
    15. ...

    Wink

    Wednesday, November 3, 2010 10:31 AM
  • User-671867248 posted

    Hi tbbm

    Thanks for your post it helped me resolve my issue of not able to find the microsoft excel application on a 64 bit Win2008 server.

    Wednesday, November 30, 2011 12:16 AM
  • User1929291559 posted

    As others have mentioned you can find the GUID alias for MS Word in the registry, but I couldn't find it as described

    Instead under HKEY_CLASSES_ROOT\Word.Application.12\CLSID listed an ID that matched with my DCOM, still testing if this solves my root problem with Word interop, but I'll keep you posted.

    I see several versions of Word.Application.* in my registry, 11=Word 2003, 12=Word 2007 and 14=Word 2010 (link)

    I'm using Windows Server 2008 x64 with Word 2007 installed (only office app).

    HTH

    Wednesday, October 17, 2012 8:02 AM