locked
Problem with running test under debugger RRS feed

  • Question

  • I have some unit tests that work fine when I "Run Selection" or equivalent but not when I "Debug Selection". When I do the latter i get an error

    "An exception of type 'System.IO.FileNotFoundException' occurred in mscorlib.dll and wasn't handled before a managed/native boundary
    Additional information: Could not load file or assembly 'Microsoft.VisualStudio.TestTools.DataCollection.SystemInfo, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified."

    These test run in debug for other developers with machines that should be set up in an identical way. I am running VS 2010 Professional SP1 and Windows 7 Professional SP1. I believe the installations of everything are completely standard.

    Has anyone any insight into why I might get this error or what I might do to fix it. I have tried tinkering with the test settings to no avail.

    David

    Friday, March 23, 2012 6:10 PM

All replies

  • Hi David,

    Thank you for visiting the MSDN forum.

    Did you change the settings in your VS? If you create a new unit test, whether it has the same issue?

    It seems that it couldn't download the .dll file. If you change the platform to “Any CPU”, and debug it, does it have the same issue?

    Try to reset your VS settings, and then debug it with the default setting, check it.

    Reference: http://social.msdn.microsoft.com/Forums/en/vsunittest/thread/4815d534-6564-4928-a4fb-ddfe09fade1c

    If no help, would you mind sharing us a simple project? We try to debug it with our computer.

    If there's any concern, please feel free to let me know.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Monday, March 26, 2012 7:05 AM
  • Hi David,

    Any update? Could you get the useful information from my reply?

    Would you mind letting us know the result of the suggestion?

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, March 28, 2012 2:10 AM
  • i have the same problem but this for me it is by an external dll which can't generate a PDB file 

    i got this error

    An exception of type 'System.ArgumentException' occurred in test.dll and wasn't handled before a managed/native boundary

    thanks for your contribution

    Thursday, December 14, 2017 9:42 AM
  • Hi amine 2,

    Since this case was closed for a long time, if you get any test issue, you could open a new case in this forum, we will follow it in time. Of course, I will unmark the reply.

    Sincerely,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, December 14, 2017 9:45 AM