none
Can't export my database to BACPAC

    Question

  • Hello,

    I recently changed the pricing tier of my database from Standard 1600 DTUs to Hyperscale which seemed to fit perfectly my needs to have a better control over the pricing/scaling/recovery.

    It was pretty good the first day and suddenly our database started to timeout all the time today. (We don't have more trafic than yesterday, CPU < 5% all the time).

    The online wizard says I have locks on database which I don't. I've tried to scale up to see if there is an improvement but it takes forever (4h and still scaling so far). I tried to turn off my whole production server to let the database breathe during the scaling/export.

    So I really want to move as quick as possible from that Hyperscale database. I decided to export my database to BACPAC (and create a new one with Standard pricing, at least it works) but I can't, I always get a timeout after "Extracting schema from database" (after 30-45 minutes). My database is around 30-35Gb. I've tried unchecking the log tables, same result.

    I've tried using SSMS, SqlPackage.exe (latest version for both).

    Thank you for your help

    Wednesday, June 12, 2019 12:39 PM

All replies

  • We need to get this to support so that an engineer can work with you to resolve the issue.

    If you have an Azure support plan, please file a ticket with support. If you don't have an Azure support plan, please send your Azure subscription GUID to AzCommunity at Microsoft.com, we will send back instructions to have a full-fledged incident ticket created to address this issue.

    Please reference this forum thread in your email. Thank you for your persistence. 

     
    Monday, June 17, 2019 12:07 PM
    Moderator
  • Exporting Hyperscale database instance is currently not supported. 
    Thursday, June 20, 2019 9:18 PM
    Moderator
  • Just confirming my response with the following:

    Data Migration Questions (link):

    Friday, June 21, 2019 3:56 PM
    Moderator