locked
MSDN Library for VS2008 SP1 in Vista Enterprise SP1 demands WinXP SP2 RRS feed

  • Question

  • Hi all,

     

    I'm hoping someone could help me with this one.

    I downloaded and installed VS2008 Professional SP1. As per its readme file (where it states that the MSDN Library for it must be installed separately), I downloaded the MSDN Library SP1 ISO and burned it.

    The problem is that, when I try to install, it stops at the Requirements and Software Prerequisites and says that it requires Windows XP SP2 to proceed, which would be fine if I was running XP...

     

    I’m running Windows Vista Enterprise x32 SP1 and the system requirements of the MSDN Library for VS2008 SP1 state “Windows Server 2003 Service Pack 2; Windows Server 2008; Windows Vista; Windows XP Service Pack 2”.

     

    Any help would be greatly appreciated.

     

    SS

    Tuesday, September 23, 2008 10:33 AM

Answers

  • Found an answer in another location (Kevin Dente's Blog).
    His post was about the same problem but with VS2008 itself (mine installed OK), but the solution worked:

    1. Start regedit.exe with "Run As Administrator"
    2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
    3. Back it up
    4. Delete all entries which end with "setup.exe" (not exactly what Kevin says, but I was desperate)
    5. Rerun the install
    Thanks for your time and sorry for posting before exhausting the first 10 pages of Google hits. Smile
    Tuesday, September 23, 2008 11:25 AM

All replies

  • Found an answer in another location (Kevin Dente's Blog).
    His post was about the same problem but with VS2008 itself (mine installed OK), but the solution worked:

    1. Start regedit.exe with "Run As Administrator"
    2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
    3. Back it up
    4. Delete all entries which end with "setup.exe" (not exactly what Kevin says, but I was desperate)
    5. Rerun the install
    Thanks for your time and sorry for posting before exhausting the first 10 pages of Google hits. Smile
    Tuesday, September 23, 2008 11:25 AM
  •  

    I had the same problem with MSDN VS2008 SP1 - VS2008 SP1 installed fine for me.

    I am installing on a Vista Business machine and I am using Virtual CloneDrive to mount the ISO image.

     

    After reading your follow-up, I looked at the Properties-Compatibility settings of the setup.exe and autorun.exe files.

    Sure enough, the Setup\setup.exe had the "Compatibility mode" checked for Windows SP (Service Pack 2). I had to click "Show settings for all users" to see this. After unchecking this, I was able to install with no problem.

     

    I would check the following files for their Compatibility setting: autorun.exe and setup.exe in the root directory of the installation folder, and the setup.exe file in the Setup folder.

     

    I don't know if the compatibility setting was checked because of the virual drive mount or not - when I get time I will burn the image to DVD and try the install again.

     

     

    VCMonkey

     

     

    Friday, September 26, 2008 8:06 PM