none
How do I resolve a Visual Studio MPF 15.0 Dependency Alert so that I may install Zebble for Xamarin extension?

    Question

  • Using Visual Studio 2015 Update 3, I am trying to install the Zebble for Xamarin extension via the Tools > Extensions and Updates dialog box. When I click download I get the following Dependency Alert:

    The following reference must be present before installation can continue: Visual Studio MPF 15.0

    A tip at the bottom advises:

    To obtain a reference, click its name, look for it on the Online, or search for it on the Internet. Restart Visual Studio after installing the references above to use this extension.

    I've tried:

    • Clicking the name but it appears to be unclickable
    • Searching for it on the Internet and have only come across Visual Studio 2017 RC issues linking to different githubs
    • Moved by Nayana A S Wednesday, April 05, 2017 3:29 AM Related to VS
    Tuesday, April 04, 2017 7:47 PM

Answers

  • Hi zacglenn,

    Welcome to the MSDN forum.

    >>The following reference must be present before installation can continue: Visual Studio MPF 15.0

    Please install the latest extension (v3.96) which removes this dependency and we can know it from the Zebble download page. Now you can directly download this extension or go to Tools-Extensions and Updates-Online to search 'Zebble' to install and since it is released the latest version on April/05/2017.

    I tested it on my VS 2015 and the installation works fine like the following:

    Meanwhile, when I research this issue and it looks like I found you reported this issue and solved it in here:

    http://stackoverflow.com/questions/43212498/how-do-i-resolve-a-visual-studio-mpf-15-0-dependency-alert-so-that-i-may-install. If so, I'm so glad to hear that your issue is solved :)

    If not, please feel free to let me know, I will help you research this issue.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, April 06, 2017 5:24 AM
    Moderator

All replies

  • The query posted by you has not reached the right forum. In order to assist best on your query, I am moving the query to the right forum. 

    Wednesday, April 05, 2017 3:29 AM
  • Hi zacglenn,

    Welcome to the MSDN forum.

    >>The following reference must be present before installation can continue: Visual Studio MPF 15.0

    Please install the latest extension (v3.96) which removes this dependency and we can know it from the Zebble download page. Now you can directly download this extension or go to Tools-Extensions and Updates-Online to search 'Zebble' to install and since it is released the latest version on April/05/2017.

    I tested it on my VS 2015 and the installation works fine like the following:

    Meanwhile, when I research this issue and it looks like I found you reported this issue and solved it in here:

    http://stackoverflow.com/questions/43212498/how-do-i-resolve-a-visual-studio-mpf-15-0-dependency-alert-so-that-i-may-install. If so, I'm so glad to hear that your issue is solved :)

    If not, please feel free to let me know, I will help you research this issue.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, April 06, 2017 5:24 AM
    Moderator
  • Thank you Sara
    Friday, April 07, 2017 3:40 PM