locked
CRM 3.0 "Server might be unavailable". RRS feed

  • Question

  • Hi,

    I'm having an issue with CRM 3.0

    Clients get this error message where it says "Server might be unavailable".

    Server is running, services are running, everything looks fine, so i started the Environment Diagnostics Wizard and i get the following:

    Some of the domain controllers do not appear to be running. The following list of servers should be checked.
    PrivUserGroup {9cd76ed6-ec49-4e29-b65d-9758fd5b17fa}
    ReportingGroup {9cd76ed6-ec49-4e29-b65d-9758fd5b17fa}
    SQLAccessGroup {9cd76ed6-ec49-4e29-b65d-9758fd5b17fa}
    UserGroup {9cd76ed6-ec49-4e29-b65d-9758fd5b17fa}

    I've tried to repair the CRM installation but it fails with this error at the end:

    Error| Install exception.System.Exception: Action Microsoft.Crm.Setup.Server.RepairBulkOperationProcessAction failed. ---> System.Web.Services.Protocols.SoapException: Server was unable to process request.
       at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
       at Microsoft.Crm.Metadata.MetadataWebService.GetDataSet()
       at Microsoft.Crm.Metadata.DynamicMetadataCache.LoadDataSetFromWebService()
       at Microsoft.Crm.Metadata.DynamicMetadataCache..ctor(LoadMethod method)
       at Microsoft.Crm.Metadata.MetadataCache.LoadCacheNoLock()
       at Microsoft.Crm.Metadata.MetadataCache.LoadCache()
       at Microsoft.Crm.Metadata.MetadataCache.GetEntity(String entityName)
       at Microsoft.Crm.BusinessEntities.BusinessEntity.ProcessMetadataMap(String platformName)
       at Microsoft.Crm.BusinessEntities.BusinessProcessObject..ctor(Type entityType, String platformName)
       at Microsoft.Crm.BusinessEntities.BusinessProcessObject..ctor(Type entityType)
       at Microsoft.Crm.Setup.Server.BulkOperationActionHelper.VerifyWorkflowRuleExists(IDictionary parameters)
       at Microsoft.Crm.Setup.Server.BulkOperationActionHelper.RepairWorklowRule(IDictionary parameters)
       at Microsoft.Crm.Setup.Server.RepairBulkOperationProcessAction.Do(IDictionary parameters)
       at Microsoft.Crm.Setup.Common.Action.ExecuteAction(Action action, IDictionary parameters, Boolean undo)
       --- Fin de la trace de la pile d'exception interne ---
       at Microsoft.Crm.Setup.Common.Action.ExecuteAction(Action action, IDictionary parameters, Boolean undo)
       at Microsoft.Crm.Setup.Common.Installer.Install(IDictionary stateSaver)
       at Microsoft.Crm.Setup.Common.ComposedInstaller.InternalInstall(IDictionary stateSaver)
       at Microsoft.Crm.Setup.Common.ComposedInstaller.Install(IDictionary stateSaver)
       at Microsoft.Crm.Setup.Server.ServerSetup.Repair(IDictionary data)
       at Microsoft.Crm.Setup.Server.ServerSetup.Run()
    Info| Microsoft CRM 3.0 Server Setup Failed.
    Info| Microsoft CRM 3.0 Server Setup Setup did not complete successfully.

    Anyone ever encountered a similar problem ?

    Regards,

    trep
    • Moved by Max Wang_1983 Tuesday, April 26, 2011 6:13 PM forum consolidation (From:Architecture, Tools, and Process for ISVs)
    Thursday, May 31, 2007 5:45 PM

All replies

  • I have the same problem... Do you know how to solve it?
    Tuesday, June 5, 2007 4:27 PM
  •  

    The 2nd "domain controller" issue was because these groups had been moved in
    AD from the Users node to the Domain Controllers node.  Dragging them back
    fixed that diagnostic error.

    Wednesday, September 19, 2007 5:27 AM
  • I too am having the same error, except I'm only experiencing your first Error.

     

    The repair tool didn't seem to do anything other than tell me that CRM server is working properly (Which it obviously isn't)

     

    Anyone have any advice for this problem?

     

    Thanks.

    Monday, September 24, 2007 6:44 PM
  • A CRM repair installation is designed to repair missing/corrupt files and registry keys, but does not resolve Active Directory problems (which it looks like this is).

     

    I'd check that all your domain controllers are working properly, that replication is working properly, and the 4 CRM groups (PrivUser, SQLAccess, User and Reporting) all exist.

     

    If that all looks OK you try running the CRM Redeployment tool, as this does resolve some AD issues

     

    Wednesday, October 31, 2007 10:19 PM