locked
Access Webservice from an untrusted Domain RRS feed

  • Question

  • I m new to Web Services.

    I have created a webservice on Server1 in Domain dOne. I need to access this web service from a client machine on another domain dTwo. These 2 domains dont have any trust established between them.

    When I access the webservice using IE from a machine in the dTwo domain, it asks for credentials. If I supply valid credentials belonging to dOne, I am able to access the webservice. My requirement is, it shouldnt ask me for credentials.

    Please help.
    Friday, June 29, 2007 11:26 AM

Answers

  • Hi,

     

    If you use Windows Authentication for your web service, IIS will always ask you for the user credentials if the service and the client application are in different windows domains. (In addition Windows authentication only works for intranet scenarios).

    The only solution here to avoid passing credentials is to use Anonymous Authentication or Client-Certificate authentication (Requires X509 certificates for the clients).

     

    Regards,

    Pablo.

    Friday, June 29, 2007 2:23 PM

All replies

  • Hi,

     

    If you use Windows Authentication for your web service, IIS will always ask you for the user credentials if the service and the client application are in different windows domains. (In addition Windows authentication only works for intranet scenarios).

    The only solution here to avoid passing credentials is to use Anonymous Authentication or Client-Certificate authentication (Requires X509 certificates for the clients).

     

    Regards,

    Pablo.

    Friday, June 29, 2007 2:23 PM
  • Hi,

     

    I have created a webservice on Server KDHIntranet in Domain KDH. I need to access this web service from a client machine on another domain KDHPeru. These 2 domains have trust established between them, but if I do not supply credentials, I am not able to acces the web service.

     

    The specific case is related to Rights management configuration between two trusted domains. If I do not provide credentials for an user from another domain (that have credentials to open the document), I am not able to open the document.

     

    ¿What is going wrong?

     

    Thanks in advance

     

    Carlos.

     

    Wednesday, July 4, 2007 7:57 PM