none
wince 6 RRS feed

  • Question

  • Hi all,

    I am working on wince 6 platform.while building I am getting some errors.Please help me to solve it.

    BUILD: [01:0000001197:PROGC ] Linking E:\WINCE600\platform\Atlas_FreescaleiMX512\lib\ARMV4I\retail\pmicPdk_mc13892.lib
    BUILD: [00:0000001210:PROGC ] Building LIB Pass in E:\WINCE600\PLATFORM\Atlas_FreescaleiMX512\SRC\DRIVERS\PMIC\MC13892\SDK\ directory.
    BUILD: [01:0000001220:PROGC ] Linking E:\WINCE600\platform\Atlas_FreescaleiMX512\lib\ARMV4I\retail\pmicSdk_mc13892.lib
    BUILD: [00:0000001232:PROGC ] Building LIB Pass in E:\WINCE600\PLATFORM\Atlas_FreescaleiMX512\SRC\DRIVERS\DVFC\COMMON\ directory.
    BUILD: [01:0000001242:PROGC ] Linking E:\WINCE600\platform\Atlas_FreescaleiMX512\lib\ARMV4I\retail\dvfc.lib
    BUILD: [00:0000001248:PROGC ] Building LIB Pass in E:\WINCE600\PLATFORM\Atlas_FreescaleiMX512\SRC\DRIVERS\DVFC\MC13892\ directory.
    BUILD: [01:0000001258:PROGC ] 
    BUILD: [01:0000001264:PROGC ] Linking E:\WINCE600\platform\Atlas_FreescaleiMX512\lib\ARMV4I\retail\dvfc_mc13892.lib
    BUILD: [00:0000001277:PROGC ] Building LIB Pass in E:\WINCE600\PLATFORM\Atlas_FreescaleiMX512\SRC\DRIVERS\I2C\SDK\ directory.
    BUILD: [01:0000001287:PROGC ] Linking E:\WINCE600\platform\Atlas_FreescaleiMX512\lib\ARMV4I\retail\i2csdk.lib
    BUILD: [00:0000001297:WARNN ] E:\WINCE600\PLATFORM\Atlas_FreescaleiMX512\SRC\DRIVERS\I2C\PDK\: Missing source file: E:\WINCE600\platform\common\lib\ARMV4I\retail\i2c_mx51_fsl_v2.lib.
    BUILD: [00:0000001301:PROGC ] Building LIB Pass in E:\WINCE600\PLATFORM\Atlas_FreescaleiMX512\SRC\DRIVERS\I2C\PDK\ directory.
    BUILD: [01:0000001311:ERRORE] NMAKE :  U1073: don't know how to make 'E:\WINCE600\platform\common\lib\ARMV4I\retail\i2c_mx51_fsl_v2.lib'
    BUILD: [01:0000001313:ERRORE] NMAKE.EXE TargetLibFiles  -i -c BUILDMSG=Stop.  BUILDROOT=E:\WINCE600\PLATFORM\Atlas_FreescaleiMX512 CLEANBUILD=1 LINKONLY=1 NOPASS0=1 failed - rc = 2
    BUILD: [00:0000001314:PROGC ]                        Files  Warnings  Errors
    BUILD: [00:0000001315:PROGC ] Midl                       0         0       0
    BUILD: [00:0000001316:PROGC ] Message                    0         0       0
    BUILD: [00:0000001317:PROGC ] Precomp Header             0         0       0
    BUILD: [00:0000001318:PROGC ] Resource                   0         0       0
    BUILD: [00:0000001319:PROGC ] MASM                       0         0       0
    BUILD: [00:0000001320:PROGC ] SHASM                      0         0       0
    BUILD: [00:0000001321:PROGC ] ARMASM                     7        10       0
    BUILD: [00:0000001322:PROGC ] MIPSASM                    0         0       0
    BUILD: [00:0000001323:PROGC ] C++                       10         0       0
    BUILD: [00:0000001324:PROGC ] C                         60         0       0
    BUILD: [00:0000001325:PROGC ] Static Libraries          11         0       0
    BUILD: [00:0000001326:PROGC ] Exe's                      0         0       0
    BUILD: [00:0000001327:PROGC ] Dll's                      4         0       0
    BUILD: [00:0000001328:PROGC ] Preprocess deffile         1         0       0
    BUILD: [00:0000001329:PROGC ] Resx                       0         0       0
    BUILD: [00:0000001330:PROGC ] CSharp Compile             0         0       0
    BUILD: [00:0000001331:PROGC ] Other                      0         2       2
    BUILD: [00:0000001332:PROGC ] 
    BUILD: [00:0000001333:PROGC ] Total                     93        12       2
    BUILD: [00:0000001334:PROGC ] 
    BUILD: [00:0000001335:PROGC ] 12 Warnings,  2 Errors
    BUILD: [00:0000001336:PROGC ] GetSystemTimes (seconds): Idle: 98    Kernel: 116   User: 18   
    BUILD: [00:0000001337:PROGC ] Elapsed  time  (seconds): 67   
    Build for Windows CE (Release 601) (Built on Aug 17 2006 15:18:52)
    File names: Build.log Build.wrn Build.err Build.dat
    Sysgening platform E:\WINCE600\platform\Atlas_FreescaleiMX512
    \WINCE600\build.err

    BLDDEMO: There were errors building ATLAS-iMX512

    ATLAS-iMX512 - 3 error(s), 46 warning(s)
    ========== Rebuild All: 0 succeeded, 1 failed, 0 skipped ==========

    Monday, February 25, 2013 9:03 AM

All replies

  • While building I2C module "E:\WINCE600\PLATFORM\Atlas_FreescaleiMX512\SRC\DRIVERS\I2C\PDK\" It is not able to link to the library :

    i2c_mx51_fsl_v2.lib at the location "E:\WINCE600\platform\common\lib\ARMV4I\retail"

    First check if "i2c_mx51_fsl_v2.lib" is present or not.If present check the pah is correct or not ?

    Otherwise

    check how/Who is generating "i2c_mx51_fsl_v2.lib" and why it is not getting generated ? Any catalog item is required to be enabled ???

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Monday, February 25, 2013 9:26 AM
  • Hi Misbah,

    I checked in i2c_mx51_fsl_v2.lib at the location "E:\WINCE600\platform\common\lib\ARMV4I\retail

    but its not there.

    I given full search in total wince 600 for i2c_mx51_fsl_v2.lib.

    But I could not find it.

    please suggest me any further methods for solve the issue.

    Monday, February 25, 2013 1:07 PM
  • Hi Bhagath,

    Can you make a quick check whether you added "makefile" in E:\WINCE600\PLATFORM\Atlas_FreescaleiMX512\SRC\DRIVERS\I2C\PDK\ folder?? Also I'd suggest to look in other directories of your driver code.

    Generally if you look for this "NMAKE :  U1073: don't know how to make" error, this occurs when a makefile is not added in a directory which is having a sources file.

    Hope this helps..

    Monday, February 25, 2013 1:17 PM
  • Hi Misbah,

    I look at the respective folders I saw both makefile and sources file there.

    the makefile content is below:-

    #
    # DO NOT EDIT THIS FILE!!!  Edit .\sources. if you want to add a new source
    # file to this component.  This file merely indirects to the real make file
    # that is shared by all the components of Windows CE
    #
    !INCLUDE $(_MAKEENVROOT)\makefile.def

    sources file content is below:-


    !IF "$(BSP_I2CBUS1)" == "" && "$(BSP_I2CBUS2)" == ""
    SKIPBUILD=1
    !ENDIF

    TARGETNAME=i2c
    RELEASETYPE=PLATFORM
    TARGETTYPE=DYNLINK

    DLLENTRY=_DllMainCRTStartup

    TARGETLIBS=\
        $(_SYSGENSDKROOT)\lib\$(_CPUINDPATH)\coredll.lib \
        $(_SYSGENOAKROOT)\lib\$(_CPUINDPATH)\ceddk.lib \
        $(_TARGETPLATROOT)\lib\$(_CPUDEPPATH)\cspddk.lib

    SOURCELIBS=\
        $(_PLATCOMMONLIB)\$(_CPUINDPATH)\i2c_$(_SOCDIR).lib

    DEFFILE=$(_PLATCOMMONLIB)\$(_CPUINDPATH)\i2c_$(_COMMONSOCDIR).def

    SOURCES=\
        bspi2c.c

    Then what will be the problem?


    • Edited by Rohith_88 Monday, February 25, 2013 1:35 PM
    Monday, February 25, 2013 1:33 PM
  • Hi Bhagathkg,

    The file wince 600 for i2c_mx51_fsl_v2.lib is not there becoz it is not getting created. You should look into why this .lib is not getting created.

    Monday, February 25, 2013 2:02 PM
  • Hi Bhagath,

    Just take a look on following links once. Hope that might help.

    Link1  Link2  Link3

    Also I agree with what @MobileGeek88 is saying.

    Happy Debugging!!


    • Edited by deepak_ Monday, February 25, 2013 2:08 PM
    Monday, February 25, 2013 2:07 PM
  • Check in the following directory of your wince installation.Browse to this location in solution explorer of VS and try to build this library by right click menu.Check whether this lib is getting created and then build the I2C driver available in your BSP.
    \WINCE600\PLATFORM\COMMON\SRC\SOC\MX51_FSL_V2_PDK1_7\I2C
     
     
    Regards,
    Prabu [eMVP]
    Monday, February 25, 2013 3:41 PM
  • Hi Prabu,

    There is no WINCE600\PLATFORM\COMMON\SRC\SOC\MX51_FSL_V2_PDK1_7\I2C  path at all.But

    there have these folders.

    MX51_FSL_V2

    MX35_FSL_V2_PDK1_5(excluded build)

    COMMON_FSL_V2

    COMMON_FSL_V2_PDK1_5((excluded build)

    Please suggest any further solution.

    Tuesday, February 26, 2013 4:24 AM
  • The path mentioned by prabu is not there under your BSP ?

    If yes try searching all the "sources" file which should be building "i2c_mx51_fsl_v2.lib"

    i mean there should be a source file which when compiled should generate "i2c_mx51_fsl_v2.lib" which contains function definitions and needs to be statically linked with your i2c driver file.

    Among the folders you have mentioned above. You should look into that first "specially (exclude build)" and if you find it will generate "i2c_mx51_fsl_v2.lib" then include it into the build ... build it and then build the i2c driver.

    --- misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Tuesday, February 26, 2013 5:02 AM
  • Hi Misbah,

    I tried many ways but still I am facing the issue.Please let me know the paths are case sensitive?

    I saw some paths in build log like below

    e:\wince600\platform\atlas_freescaleimx512\src\inc\args.h

    but actually its like 

    e:\wince600\platform\atlas_freescaleimx512\SRC\INC\args.h

    Is it make any problem while building?

    Tuesday, February 26, 2013 11:01 AM
  •  
    WinCE compiler are non case sensitive.So it should not create any problem.
     
    Did you tried to find out the source code folder of this i2c_mx51_fsl_v2.lib library?
     
    The error clearly states that it didn�??t find this library.So you have to find the source folder of this library which is mostly found in the SOC folder or inside your platform directly.Unless you find the source of that library and build the same otherwise you will not be able to move forward in the build.
     
    Regards,
    Prabu [eMVP]
    Tuesday, February 26, 2013 12:58 PM
  • Hi Prabu,

    I cleared the i2c_mx51_fsl_v2.lib by rebuilding the MX51_FSL_V2 folder.But now I am facing some other errors.

    BUILD: [00:0000001598:WARNN ] File: E:\WINCE600\platform\Atlas_FreescaleiMX512\lib\ARMV4I\retail\wavedev2_sgtl5000.lib does not exist (2).
    BUILD: [00:0000001599:WARNN ] File: E:\WINCE600\platform\Atlas_FreescaleiMX512\lib\ARMV4I\retail\spdifdev.lib does not exist (2).
    BUILD: [00:0000001600:WARNN ] File: E:\WINCE600\platform\Atlas_FreescaleiMX512\lib\ARMV4I\retail\battdrvr_fake.lib does not exist (2).
    BUILD: [00:0000001601:WARNN ] File: E:\WINCE600\platform\Atlas_FreescaleiMX512\lib\ARMV4I\retail\vpu.lib does not exist (2).
    BUILD: [00:0000001602:WARNN ] File: E:\WINCE600\platform\Atlas_FreescaleiMX512\lib\ARMV4I\retail\dummy.lib does not exist (2).
    BUILD: [00:0000001603:WARNN ] File: E:\WINCE600\platform\Atlas_FreescaleiMX512\lib\ARMV4I\retail\bt.lib does not exist (2).
    BUILD: [00:0000001604:WARNN ] File: E:\WINCE600\platform\Atlas_FreescaleiMX512\lib\ARMV4I\retail\XRRendererOpenGL.lib does not exist (2).
    BUILD: [00:0000001605:WARNN ] File: E:\WINCE600\platform\Atlas_FreescaleiMX512\lib\ARMV4I\retail\csp_serial.lib does not exist (2).
    BUILD: [00:0000001611:PROGC ] Building LIB Pass in E:\WINCE600\PLATFORM\Atlas_FreescaleiMX512\src\DRIVERS\CSPDDK\DLL\ directory.
    BUILD: [01:0000001621:ERRORE] NMAKE :  U1073: don't know how to make 'E:\WINCE600\platform\COMMON\lib\ARMV4I\retail\ddk_common_fsl_v2.def'
    BUILD: [01:0000001623:ERRORE] NMAKE.EXE TargetLibFiles  -i -c BUILDMSG=Stop.  BUILDROOT=E:\WINCE600\PLATFORM\Atlas_FreescaleiMX512 CLEANBUILD=1 LINKONLY=1 NOPASS0=1 failed - rc = 2
    BUILD: [00:0000001624:PROGC ]                        Files  Warnings  Errors
    BUILD: [00:0000001625:PROGC ] Midl                       0         0       0
    BUILD: [00:0000001626:PROGC ] Message                    0         0       0
    BUILD: [00:0000001627:PROGC ] Precomp Header             0         0       0
    BUILD: [00:0000001628:PROGC ] Resource                   0         0       0
    BUILD: [00:0000001629:PROGC ] MASM                       0         0       0
    BUILD: [00:0000001630:PROGC ] SHASM                      0         0       0
    BUILD: [00:0000001631:PROGC ] ARMASM                     0         0       0
    BUILD: [00:0000001632:PROGC ] MIPSASM                    0         0       0
    BUILD: [00:0000001633:PROGC ] C++                        7         0       0
    BUILD: [00:0000001634:PROGC ] C                         25         0       0
    BUILD: [00:0000001635:PROGC ] Static Libraries           5         0       0
    BUILD: [00:0000001636:PROGC ] Exe's                      0         0       0
    BUILD: [00:0000001637:PROGC ] Dll's                     22         0       0
    BUILD: [00:0000001638:PROGC ] Preprocess deffile         0         0       0
    BUILD: [00:0000001639:PROGC ] Resx                       0         0       0
    BUILD: [00:0000001640:PROGC ] CSharp Compile             0         0       0
    BUILD: [00:0000001641:PROGC ] Other                      0         3       2
    BUILD: [00:0000001642:PROGC ] 
    BUILD: [00:0000001643:PROGC ] Total                     59         3       2
    BUILD: [00:0000001644:PROGC ] 
    BUILD: [00:0000001645:PROGC ] 3 Warnings,  2 Errors
    BUILD: [00:0000001646:PROGC ] GetSystemTimes (seconds): Idle: 152   Kernel: 169   User: 13   
    BUILD: [00:0000001647:PROGC ] Elapsed  time  (seconds): 91   
    Build for Windows CE (Release 601) (Built on Aug 17 2006 15:18:52)
    File names: Build.log Build.wrn Build.err Build.dat
    E:\WINCE600\PLATFORM\Atlas_FreescaleiMX512\src\DRIVERS\dirs - 2 error(s), 107 warning(s)
    ========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========

    please help me to solve this one also.Thanks in advance.

    Tuesday, February 26, 2013 2:55 PM
  • It looks like your common SOC directory doesn�??t build properly.Did you tried giving �??ReBuild Current BSP and Subprojects�?�?
     
    Also check whether you have any conflicting folders in your SOC directory.
     
     
    Regards,
    Prabu [eMVP]
    Wednesday, February 27, 2013 6:04 AM
  • Hi Prabhu,

    My client given the dll of their driver.How I can include this to my new build in wince 6?

    I have .bib , .reg, .pdb, .rel, .map, makefile and sources

    please let me know using these can I make one build?if yes please describe me.

    Actually they given this for wince 7 platform.but I don't have it so here wince 6 is using.

    Wednesday, February 27, 2013 8:55 AM
  • Hey Bhagath,

    You can go on with following method:

     Adding Driver to the OS Design
    1. Editing project.reg file
    Open "<your driver name>.reg” file and copy the whole content.
    From the “ Solution Explorer” view, expand “<your OS design name> → Parameter Files → CEPC: x86” and open "project.reg" file. Add the copied content from the previous step to this file in the end.
    Alternatively, "#include "$(<any relative path in PB_DIR>)\<your driver name>.reg" can be added in "project.reg" file.
    e.g #include "$(_FLATRELEASEDIR)\<your driver name>.reg

    2.  Editing project.bib file
    From the “ Solution Explorer” view, expand “<your OS design name> → Parameter Files → CEPC: x86” and open "project.bib" file.
    Under the "MODULES" section, copy the following line
           <your driver name>.dll      Driver's Location\<your driver name>.dll                    NK  SHK
    e.g. "<your driver name>.dll      $(_FLATRELEASEDIR)\<your driver name>.dll            NK  SHK"

    Hope this helps.. :)


    • Edited by deepak_ Wednesday, February 27, 2013 9:18 AM
    • Proposed as answer by MobileGeek88 Wednesday, February 27, 2013 9:26 AM
    Wednesday, February 27, 2013 9:18 AM
  • For Freescale (your BSP) the path mentioned will not have "CEPC: x86"

    Also go through these links :

    http://stackoverflow.com/questions/1277448/how-can-i-add-a-binary-device-driver-in-platform-builder-for-windows-ce-6-0

    http://us.generation-nt.com/answer/how-import-driver-into-wince-bsp-help-88126342.html

    In the blog by Bruce, things are explained in detailed.

    --- misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Wednesday, February 27, 2013 11:10 AM
  • Hi Misbah,

    There is one problem.I have wince 6 setup here.But the .dll s are build in wince 7.So I tried to include in wlanconfig application .bib file.But showing many errors.

    iMX512\RelDir\Atlas_FreescaleiMX512_ARMV4I_Release\touch_mc13892.dll to E:\WINCE600\OSDesigns\ATLAS-iMX512\RelDir\Atlas_FreescaleiMX512_ARMV4I_Release\touch.dll for debugger

    Pass 1...

    Warning: Unable to do imports from ppp.dll to RSAENH.dll - will late bind
    Warning: Unable to do imports from schannel.dll to RSAENH.dll - will late bind
    Warning: Unable to do imports from k.schannel.dll to RSAENH.dll - will late bind
    Warning: Unable to do imports from eapol.dll to RSAENH.dll - will late bind
    Warning: Unable to do imports from eapchap.dll to RSAENH.dll - will late bind
    Warning: Unable to do imports from crypt32.dll to RSAENH.dll - will late bind
    Warning: Unable to do imports from k.crypt32.dll to RSAENH.dll - will late bind
    Error: Can't find import NdisFreeMdl in ndis.dll
    Error: Can't find import NdisFreeMdl hint 117 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisFreeNetBufferListPool in ndis.dll
    Error: Can't find import NdisFreeNetBufferListPool hint 122 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisAllocateNetBufferListPool in ndis.dll
    Error: Can't find import NdisAllocateNetBufferListPool hint 40 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisFreeNetBufferList in ndis.dll
    Error: Can't find import NdisFreeNetBufferList hint 120 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisAllocateNetBufferAndNetBufferList in ndis.dll
    Error: Can't find import NdisAllocateNetBufferAndNetBufferList hint 37 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisAllocateMdl in ndis.dll
    Error: Can't find import NdisAllocateMdl hint 32 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisMIndicateReceiveNetBufferLists in ndis.dll
    Error: Can't find import NdisMIndicateReceiveNetBufferLists hint 229 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisMIndicateStatusEx in ndis.dll
    Error: Can't find import NdisMIndicateStatusEx hint 232 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisMOidRequestComplete in ndis.dll
    Error: Can't find import NdisMOidRequestComplete hint 240 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisMSetMiniportAttributes in ndis.dll
    Error: Can't find import NdisMSetMiniportAttributes hint 269 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisMSendNetBufferListsComplete in ndis.dll
    Error: Can't find import NdisMSendNetBufferListsComplete hint 263 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisAllocateMemoryWithTagPriority in ndis.dll
    Error: Can't find import NdisAllocateMemoryWithTagPriority hint 35 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisMDeregisterMiniportDriver in ndis.dll
    Error: Can't find import NdisMDeregisterMiniportDriver hint 216 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisMRegisterMiniportDriver in ndis.dll
    Error: Can't find import NdisMRegisterMiniportDriver hint 255 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Error: Can't find import NdisOpenConfigurationEx in ndis.dll
    Error: Can't find import NdisOpenConfigurationEx hint 296 in ndis.dll
    Error: Fatal import error in SDIO8787.dll
    Fatal error hit, exiting...
    makeimg: FATAL ERROR: Command returned non-zero exit code 1 (dec).
    makeimg: FATAL ERROR: Command returned non-zero exit code 1 (dec).
    E:\WINCE600\OSDesigns\ATLAS-iMX512\Labtool\wlanconfig\sources - 48 error(s), 15 warning(s)
    ========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========



    please help me to solve this.Thanks in advance 
    • Edited by Rohith_88 Thursday, February 28, 2013 4:25 AM
    Wednesday, February 27, 2013 1:44 PM
  • Bhagath,

    Win Ce 6.0 uses NDIS 5.1 but Win EC 7 uses NDIS 6.1.

    So the library functions of your WinEC7 driver might not be supported in WinCE 6 (which you are using i think).

    Wednesday, February 27, 2013 2:53 PM
  • NDIS 5.x(WinCE 6.0) is upgraded to NDIS 6.0 version in WEC7.As you are trying to add the driver which is written for WEC7 in WINCE 6.0,I don�??t think it will work because of NDIS version change.
     
     
    Check out this porting guide to port network driver from WinCE 6.0 to WEC7.If you got the source you have to backport the driver from WEC7 to WinCE 6.0 using this document.
     
     
    Regards,
    Prabu [eMVP]
    Wednesday, February 27, 2013 3:04 PM
  • Hi Prabu,

    If I get the ndis.dll from client.Can I solve this issue?Is it only depends on the ndis.dll?

    Thursday, February 28, 2013 5:17 AM
  • If you have the source code you can back port the driver from CE7 to WinCE 6.

    But since you have dll it cannot be possible. All the errors you are getting is trying to link to ndis.dll is not finding in the dll

    There for you cannot do that unless you have the correct dll.

    Why dont you ask the client to give dll for WinCE6 if they cannot share the source code.

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Thursday, February 28, 2013 7:37 AM
  • But their requirement is for wince 7.but here I don't have wince 6 os.

    if I get the ndis.dll of wince 7 can I build without error?

    please let me from where I can download the wince 7 trial version?

    Thursday, February 28, 2013 9:08 AM
  • If the requirement is for WEC7 from your client, then you need to do your development for WEC7.

    install platform builder for WEC7 ... go through this link :

    http://msdn.microsoft.com/en-us/library/jj200354.aspx

    http://www.microsoft.com/windowsembedded/en-us/downloads/download-windows-embedded-compact-ce.aspx

    Then you need to port your Freescale wince 6 BSP to WEC7, refer the below link for the procedure

    http://www.google.co.in/url?sa=t&rct=j&q=building%20wince%206%20bsp%20for%20wec7&source=web&cd=1&cad=rja&ved=0CC4QFjAA&url=http%3A%2F%2Fdownload.microsoft.com%2Fdownload%2F2%2F4%2FA%2F24A36661-A629-4CE6-A615-6B2910A1367A%2FBSP%2520Porting%2520Guide%2520for%2520Windows%2520Embedded%2520Compact%25207.pdf&ei=mSQvUbj9JIjNrQew6YFw&usg=AFQjCNHYzFDmFrCXEvewtBjRVevDapIufg&bvm=bv.43148975,bs.1,d.bmk

    http://msdn.microsoft.com/en-us/library/jj733445.aspx

    Then you have to port ndis and wlan driver at the end.

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Thursday, February 28, 2013 9:41 AM
  • Hi Misbah,

    is the bsp for imx51 evk is different for wince 6 and wince 7?

    Thursday, February 28, 2013 10:32 AM
  • BSP source shall remain the same, but there are certain changes in the architecture which you need to adopt.

    The documentation provided in the above post is sufficient to do the necessary changes required.

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Thursday, February 28, 2013 11:55 AM
  • But if I have wince 7 set up the ndis and driver porting is no need right?
    The client is sending the wince 7 compatible driver.help me asap
    Thursday, February 28, 2013 1:45 PM
  • Hi All,

    I have imx 51 evk board with me.In that have only dvi port is there.But in the wince 6 image have vga only enabled.

    By using a DVI to vga converter can I get the display from board to monitor?I mean without DVI driver can I get the signals through the DVI port?

    Thanks alot in advance.

    Thursday, February 28, 2013 1:52 PM