none
which net framework version application is using RRS feed

  • Question

  • Hi...

    If I have frmw 4.0 client profile....and my app is targeting that. If I install frmw 4.5 my app will be still using 4.0 from client profile  or 4.0 from 4.5 installation?

    Friday, June 5, 2015 10:14 AM

Answers

All replies

  • If you have 4.5 installed then it uses 4.5 as that replaces the 4.0 installation.
    Friday, June 5, 2015 11:19 AM
    Moderator
  • thanks Mike,

    but I found on my clients 4.0 client, 4.0 extended and 4.5 side by side. Should installation of 4.5 replace(remove) 4.0?

    If it does not, when I call sql.connect for example, does that call goes to 4.0 or 4.5?

    in vs I selected .NET framework 4, and I'm happy with that.

    Thing is, that I think 4.0 and 4.5 are working differently when threading is in question. No, I know they are not working the same. So I would like to keep 4.0. Or better yet, to install 4.5 but with no affect on my app 4.0 calls.

    Friday, June 5, 2015 7:19 PM
  • .NET 4.5 is an update to the .NET Framework 4.0.  So there aren't two separate frameworks.  However there are some behavior differences for apps that target 4.0. These are things that are better in 4.5, but where you might depend on the old behavior.  see

    http://blogs.msdn.com/b/dotnet/archive/2012/10/17/net-framework-4-5-off-to-a-great-start.aspx

    David


    David http://blogs.msdn.com/b/dbrowne/

    Friday, June 5, 2015 9:34 PM