none
Exceeded retry count of 10. Failed - Windows 10 - VS 2010

    Question

  • I have seen chat on this problem with no proper solution.
    I have never had the problem before but over the last 2 days I get it every second build for the 'startup project' in a multi project solution  first build the file is not locked

    I have checked

    There is NO executable in Task Manager
    I have tried running Visual Studio as administrator but that makes no difference
    Try to delete the executable in File Manager errors because the file 'IS' locked

    The only things which appear to work:

    a) Change the startup project to another project which releases the exe,
    Build then the offending exe builds OK, change the startup project back, make changes, build, test Change startup project etc. etc. 
    b) Close Visual Studio delete the bin folder or Executable file re-open VS - I can make changes and 1 build until the bin folder has bee re-created

    any ideas?, maybe it is a Windows 10 problem


    jnc

    Thursday, December 31, 2015 1:13 PM

Answers

  • ....moving on

    so far I have found that unticking 'Enable the Visual Studio Hosing process' then building, making changes and re-ticking 'Enable the Visual Studio Hosing process' seems to fix it

    It will now allow me to make changes build, make changes and build without problems


    jnc

    Thursday, December 31, 2015 1:29 PM

All replies

  • As usual I post then find something

    Project Properties > Debug > untick 'Enable the Visual Studio Hosing process'

    this appears to be a workable thing but I am un-sure of any implications


    jnc

    Thursday, December 31, 2015 1:22 PM
  • ....moving on

    so far I have found that unticking 'Enable the Visual Studio Hosing process' then building, making changes and re-ticking 'Enable the Visual Studio Hosing process' seems to fix it

    It will now allow me to make changes build, make changes and build without problems


    jnc

    Thursday, December 31, 2015 1:29 PM
  • Thanks for sharing your solution here, jnc:)

    Since this issue was resolved, you could mark your reply as the answer, so it would be helpful for other members who get the same issue to find the answer.

    Have a nice holiday,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, January 01, 2016 7:16 AM
    Moderator
  • It is not really clear when the error happens to you.

    If it is while creating the solution with Generate or starting the debug then it is a problem with the debug directory being unavailable for creation.

    There is a simple way to solve this in the compiler prebuild options:

    if exist "$(TargetPath).locked" del "$(TargetPath).locked"
    if exist "$(TargetPath)" if not exist "$(TargetPath).locked" move "$(TargetPath)" "$(TargetPath).locked"

    here is a screen cap for my IDE (warning it's in French :) )

    The prebuild compiler options to remove the offending previous build....

    Happy New year.


    Cyrille Precetti

    Friday, January 01, 2016 10:10 AM
  • thank you Cyrille

    the error occurred during build and failed to re-create the 'startup project' exe all the others were recreated if changed.

    I think I have the solution, time will tell.... 


    jnc

    Friday, January 01, 2016 8:22 PM
  • thank you Jack

    yes I am happy with the result so-far and have marked it as answered

    jnc


    jnc

    Friday, January 01, 2016 8:23 PM