none
C++ Color Basics works but C# Color Basics does not. RRS feed

  • Question

  • I am running 1.7 SDK on a Win 7 64 machine.  I tried to run the sample code in both c++ and C#, the C# sample loads and just displays a black image and never changes but the c++ code works just fine.  I'm wanting to use the C# code for a project, how do I get it to work or what is the difference in the two programs that is making one work and not the other?

    Thanks for your help,

    Steve


    Steve Steadman

    Wednesday, August 21, 2013 6:26 PM

All replies

  • Just an update.

    I just installed a separate USB 2.0 card in the machine to try that since I've read that the USB could have something to do with this problem.  NO LUCK, it didn't make a difference.  

    I can run the C# samples and get the facetracking ones to work, what I mean by working is that they display the wireframe face where my face is in realtime but the color image or video frame is frozen.  The "Color Basics" example just displays a black screen.

    My Kinect is the Microsoft one and I am positive it is working because I can use it in another machine.

    My motherboard is: MSI Z87-G41 PC Mate.  I'm using the onboard video card.


    Steve Steadman

    Wednesday, August 21, 2013 9:27 PM
  • If this is isolated to your managed environment only, which GPU are you using? How are the C++ samples working for you? If you can debug the issue and look at the "FrameReady" event, you will see if you are getting data from the sensor. Given that the "mesh" data is working, that means the FT is able to get the core data: color, depth and skeleton from the sensor and you are having Draw issues with the Image control.

    You might want to do some WPF tests to see if there are any graphical issues with rendering.


    Carmine Sirignano - MSFT

    Friday, August 23, 2013 5:56 PM
  • I wanted to update.

    I have two machines, one that is my development machine and the other is the machine that was supposed to run the Kinect after I developed the app.  My development machine worked with the Kinect with no problems but the new one did not, it has the MSI z87-G41 PC Mate motherboard and I used the onboard video card.  At first I read a lot of posts that said the USB bus could be giving me a problem so I went and bought two different USB 2.0 PCI cards and tried them, still no luck.  I removed the cards and tried taking the video card that was working out of my development machine and put it into the new one.  The video would actually not freeze until a face was tracked then it would lock up.  Of course this was with the sample facetracking app.  I could actually get the color basics to work with the video card from the other machine installed but facetracking would not.

    I just wanted to post what happened since many posts never get completed.  The only thing I could sum up from all this is that the motherboard was not compatible with the Kinect.  I have the I7 Intel processor in it with 8G of RAM, FYI.  I also did try removing all the devices from the USB ports except for the Kinect and still no luck.

    Best of luck,

    Steve


    Steve Steadman

    Monday, August 26, 2013 9:32 PM
  • Have you tried Windows 8? The USB issues on Windows 7 may be due to the USB driver stacks provided by the OEM. Windows 8, a lot of work went into improving that so you might have better results.

    Carmine Sirignano - MSFT

    Monday, August 26, 2013 9:56 PM