none
Several issues with Microsoft Visual Studio 2012 installation

    Question

  • I am experiencing a host of issues in my Microsoft Visual Studio 2012/Intel Fortran Compiler 2013 installation. The issues are as follows:

    ISSUES

    1) Initial Installation of Visual Studio 2012: At the very end of the Visual Studio 2012 installation, I get the following error: 

    "Please correct the following problems to ensure full product functionality.
    Microsoft Windows Operating System: The event log file is full"


    2) Compatibility of Visual Studio 2012 with my Windows 7 machine: When I run Visual studio from the main application icon, I get the following message: "This program has known compatibility issues"

    3) Command Prompt Error: I am getting 
    "ERROR: Cannot determine the location of the VS Common Tools Folder" 
    in the following command prompts:

    VISUAL STUDIO 2012

    i) VS2012 x86 Native Tools Command Prompt
    ii) VS2012x64 Cross Tools command Prompt
    iii) VS2012 ARM Cross Tools Command Prompt
    iv) VS2012x64 Native Tools Command Prompt
    v) Developer Command Prompt for VS 2012

    INTEL FORTRAN 2013

    vi) Intel Composer XE 2013 Intel(R) 64 Visual Studio 2012
    vii) Intel Composer XE 2013 IA-32 Visual Studio 2012

    ie, all of them. Here is an example, the error is identical for all abovementioned command prompts.


    4) ifort command error: When attempting to use the ifort compiler through any of the command prompts mentioned in isse 3) above, I get the following error: 
    "ifort: error #10037: could not find 'link'"


    SOLUTIONS ATTEMPTED

    For issues 1) through 4), I attempted several things:

    1) 

    i) removed all information in the %ProgramData%\Package Cache as explained in a popular MSDN blog page (https://blogs.msdn.microsoft.com/mandi/2013/08/21/visual-studio-2012-the-event-log-file-is-full-error-message/)
    ii) Checked the event log. The event log showed a warning regarding Windows 7 compatibility, which makes me think issues 1) and 2) are related.

    2) 
    i) Applied latest Visual Studio 2012 update (update 5) and using administrator privileges
    ii) re-installed Visual Studio 2012 with administrator privileges
    iii) repaired Visual Studio 2012 with administrator privileges

    3) 
    i) Added "C:\Windows\System32" to the PATH environment variables for Windows 7 as explained in a popular video (https://www.youtube.com/watch?v=Y1YhhAItgb0).

    4) 
    i) Attemped a variety of fixes as shown in my StackExchange post (http://stackoverflow.com/questions/42736589/running-simple-fortran-programs-using-intel-visual-fortran-microsoft-visual-st#comment72606504_42736589)


    COMMENTARY

    None of these solutions worked and all of issues 1 through 4 persist. Furthermore, I have been offered a completely new replacement machine as my current one is being formatted (precisely to try to tackle this issue). To my amazement, installing Visual Studio 2012 and Intel Fortran Compiler 2013 on a COMPLETELY DIFFERENT MACHINE reproduces ALL of the issues 1) through 4) noted above! 

    It may also be good to note that I can run Visual Studio 2012 despite the compatibility issues, however I am experiencing issues when I debug using the Step Into command. The program completely freezes and stops responding, in which case I have to restart everything. This is a seperate issue but I have a strong feeling the root cause is related to issues 1) through 4) above. In any case, I should not be having these problems since this is a completely new and genuine version of Microsoft Visual Studio 2012 and Intel Fortran processor. Please let me know if you have any suggestions or what the root cause of all this may be. Thanks.

    Thursday, March 16, 2017 7:38 AM

All replies

  • Also please verify me so I can add images for each of the errors presented. This might help others better understand the problem.

    Thursday, March 16, 2017 7:42 AM
  • Hi awa5114,

    Welcome to the MSDN forum.

    Usually, we discuss one issue in one thread, that can help us to research and trace this issue. For your issue, firstly we need to confirm the VS 2012 can install successfully on your computer or not. It can help us to avoid your current issue caused by the failed installation of VS 2012.Then you can try to install the Intel Fortran Compiler 2013 to check if there have the compatibility issue between them or not.

    To install VS 2012, refer to the system requirement of VS 2012 installation, please make sure your OS is upgraded to Windows 7 SP1 and all windows patches already installed. Temporality disable any antivirus software, clean up %temp% file and re-run the VS 2012 installer as administrator. To complete uninstall the VS 2012, please check this: How to uninstall Visual Studio 2012

    If the VS 2012 installation still fail, I need your help to collect the installation logs. Please use http://aka.ms/vscollect to gather the installation logs. After using it, you will find vslogs.zip under %temp% folder. Please upload the file to https://onedrive.live.com/ and share the link here.

    After the VS 2012 installation is successful, please install the Intel Fortran Compiler 2013 and see if there has any compatibility issue or not. If the issue persists, I found a troubleshot document: Troubleshooting Fortran Integration Issues with Visual Studio.  

    >> Also please verify me so I can add images for each of the errors presented

    please ask for a requirement in here to verify your account, then you can share the screenshots in here, thank you for your understanding.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 17, 2017 5:41 AM
    Moderator