locked
Published site - wrong links RRS feed

  • Question

  • Hello,

    we have published our sharepoint site outside domain.

    Unfortunately big problems with links in document library appeared.

    The url for outside users is "it.company.cz", the internal url is "sp001:55680".

    When I open the page and select Shared Documents, the site is still it.company.cz. But when select any folder in document library the site url changes to sp001:55680.

    Strange is that the mouseover url is correct but when I click it, it changes to internal url.

    Example:

    Mouseover url: http://it.compay.cz/Shared%20Documents/Forms/AllItems.aspx?RootFolder=%2fShared%20Documents%2fProjects&FolderCTID=&View=%7bBEBFF1D2%2d5910%2d4A36%2dB049%2d971F95E752E7%7d

    After click url: http://sp001:55680/Shared%20Documents/Forms/AllItems.aspx?RootFolder=%2fShared%20Documents%2fProjects&FolderCTID=&View=%7bBEBFF1D2%2d5910%2d4A36%2dB049%2d971F95E752E7%7d

    Please help.

    • Changed type Radim Sejbl Thursday, July 15, 2010 10:04 AM
    Wednesday, July 7, 2010 12:51 PM

Answers

All replies

  • Hi,

     

    It seems the AAM records are not correct.

    How did you public the url for outside, did you use the reverse proxy server like ISA Server 2006?

     

    For more information, please refer to

    http://technet.microsoft.com/en-us/library/cc261814(office.12).aspx

    http://blogs.msdn.com/b/sharepoint/archive/2007/03/06/what-every-sharepoint-administrator-needs-to-know-about-alternate-access-mappings-part-1.aspx

     

    If the issue insists, please let me know the AAM records and something like DNS records, Web application information.

     

    Hope this helps

     

    Thanks!

    Stanfford

    • Proposed as answer by Ivan Sanders Thursday, July 8, 2010 8:25 AM
    • Marked as answer by Mike Walsh FIN Thursday, July 8, 2010 8:33 AM
    • Proposed as answer by Ivan Sanders Saturday, July 17, 2010 3:59 PM
    • Marked as answer by Mike Walsh FIN Saturday, July 17, 2010 7:11 PM
    Thursday, July 8, 2010 8:18 AM
  • Hello,

    I have done everything according to the guide, unfortunately without success.

    ISA settings are following:

    Public name: Request for following websites: it.company.cz

    Link translation: Replace absolute links in web pages (ticked): sp001:55680 -> it.company.cz

    Bridging: Port 55680

    Listener: Http port 80

    To: Server: sp001.company.local, forward the original... (unticked)

     

    AAM settings:

    http://sp001:55680 Default http://sp001:55680
    http://it.company.cz Internet http://it.company.cz
    http://sp001.company.local Internet

    http://it.company.cz

     

     

    Also strange is that this problem appears only in document library. I have created picture library and this problem does not appears there.

    I have also created new document library and it has the same problem.

    We have already published another site using the same way on SPS 2 without any problems.

     

    Please tell me if you need additional info.

    Any help would be appreciated.

    Monday, July 12, 2010 11:54 AM
  • The ISA firewall’s link translator can be used to re-write the responses published Web servers send to users making requests to the published Web server. The link translator is useful when publishing Web sites that include hard-coded URLs in their responses and those URLs are not accessible from remote locations.

    For example, suppose you publish a Web site that hard codes the URLs in its responses and the hard-coded URLs include the private names of servers on the Protected Network. Such URLs would have the form http://server1/documents or http://webserver2/users. Since these are not fully qualified domain names that are accessible from the Internet, the connections requests fail. This is a common problem with some SharePoint Portal Server Web sites.

    The Link Translator solves this problem by re-writing the responses returned to the user accessing the Web site, so that the links http://server1/documents and http://webserver2/users are rewritten http://www.msfirewall.org/documents and http://www.tacteam.net/users, both of which are accessible from the Internet.

    Without implementing URL Rewite you will continue to have this behaviour.
    -Ivan

    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    Saturday, July 17, 2010 4:04 PM