none
Unable to find the report in the manifest resources. Please build the project, and try again. RRS feed

  • Question

  • The error is received when i transfer the .exe file, bin\Debug folder to another machine:
    Unable to find the report in the manifest resources. Please build the project, and try again.

    The error is issued when i try to open the form that contain the Crystal report viewer, I already checked the properties of the report file and it says "Embed Resource" in the "Build Action"

    This error is not visible on my development machine where visual studio is installed, anybody know what i should install on the other machine for this to run.

    I'm using C#, WinForms, .net 2.0, VS 2005.
    Wednesday, July 8, 2009 12:46 PM

Answers

  • The missing file to be installed on the desired PC is the following:
    C:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\BootStrapper\Packages\CrystalReports\CRRedist2005_x86.msi
    • Marked as answer by Ahmad Hajou Thursday, July 30, 2009 7:07 AM
    Thursday, July 30, 2009 7:07 AM

All replies

  • The missing file to be installed on the desired PC is the following:
    C:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\BootStrapper\Packages\CrystalReports\CRRedist2005_x86.msi
    • Marked as answer by Ahmad Hajou Thursday, July 30, 2009 7:07 AM
    Thursday, July 30, 2009 7:07 AM
  • I across this problem, the solution is to remove the name space in the ResourceName property of code behind for crystal report

    The change without name space reference would be

    public override string ResourceName {
                get {
                    return "reportName.rpt";
                }
                set {
                    // Do nothing
                }
            }
    Tuesday, December 15, 2009 2:28 PM
  • R u sure about this?
    It was long time ago, but im sure the only what i did solved the problem, i remember trying out many other solution on the net that didn't work.
    Tuesday, December 15, 2009 3:56 PM
  • Yeah i have tried it, actually when you adds up a report file to solution, it automatically attains the default NameSpace and thorws exception on runtime when report is accessed.
    For your case the error is not the part of crystal report viewer which most of the net solutions says, like most of these says that you change the crystal report references in solution.

    Wednesday, December 16, 2009 5:43 AM
  • I donno if i follow with what ur saying, but the problem that i had is with the client PC, which is where the error is generated when trying to view the error.
    So all i had to do is install that file I mentioned above on the client PC; no namespace changes.

    I may be wrong about this but it may be a different error ur getting if this is happening on ur development machine.

    Please explain further.
    Wednesday, December 16, 2009 6:45 AM
  • I was getting the same error in runtime both in development and deployment enviornment.
    But now it is fixed without any runtime installation.
    Wednesday, December 16, 2009 1:11 PM
  • Got this error in VS 2008.

    Fixed by setting the "Build Action" for the report to "Embedded Resource".

    Friday, November 5, 2010 3:25 AM
  • @ Fronde Systems Group: 

    Setting the build action to Embedded resource  is working in my local machine which has Visual studio 2003 installed. But when i deploy the same on Server (server has no .net framework installed on it), it keeps failing. I get the the following error: "ERROR Thrown from Crystal Reports ===> An undocumented error occured" which is triggered when it is Unable to find the report in the manifest resources.

    Please suggest me guys.... 

     

    Thanks

    Ravi

    kr9299@gmail.com

    Thursday, January 26, 2012 1:21 AM
  • I solve my problem with this step.

    http://atikpassion.blogspot.in/2014/08/unable-to-find-report-in-manifest.html

    Hope it will help you.


    Regards atik sarker

    Monday, April 13, 2015 10:09 AM
  • Watch this video. It will solve your problems
    https://www.youtube.com/watch?v=LmJ4a_7QnzU&feature=youtu.be
    Sunday, October 30, 2016 9:10 PM