none
Server: MSg 17, Level 16, State 1 [Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied

    Question

  • Hi,

    When I am trying to access SQL Server 2000 database from another machine i got this error

    Server: MSg 17, Level 16, State 1 [Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied

    but I could access the database on same server and in that server i could access other databases in different server.

     

     

    Wednesday, June 6, 2007 2:42 PM

Answers

  • It is possible that

    (1) Your SQL server is not allow for remote access. use SQL Server Surface Area Manager to turn the remote access on.

    (2) windows firewall blocked your server from access remotely. use window firewall configuration tool to make an exception to your server listening port.

    (3) IPSec policy of your server prevent other server from access to it. Normally turn off IPsec will help but not recommanded. contact your admin.

     

     

    Please check the guildline post for more information on how to troubleshoot connectivtiy issue, especially remote connectivity.

     

    -HTH

    Wednesday, June 6, 2007 6:21 PM

All replies

  • Wednesday, June 6, 2007 6:19 PM
    Moderator
  • It is possible that

    (1) Your SQL server is not allow for remote access. use SQL Server Surface Area Manager to turn the remote access on.

    (2) windows firewall blocked your server from access remotely. use window firewall configuration tool to make an exception to your server listening port.

    (3) IPSec policy of your server prevent other server from access to it. Normally turn off IPsec will help but not recommanded. contact your admin.

     

     

    Please check the guildline post for more information on how to troubleshoot connectivtiy issue, especially remote connectivity.

     

    -HTH

    Wednesday, June 6, 2007 6:21 PM
  •  

    Sunday, October 21, 2007 11:36 AM
  • yeap, that worked out.

    my problem was the second point
    Wednesday, September 17, 2008 11:11 PM
  • How you solved the problem ? tell me i got same problem
    Monday, October 14, 2013 8:04 AM