Starting a service from a windows network drive gives me an error "The system cannot find the path specified." RRS feed

  • Question

  • Hi,

    I have a service in a mapped network folder in Windows. While I am
    starting this service I am getting "The system cannot find the path
    specified" error message.

    Can't we run a service which is present in a network folder?

    Kindly let me know if there is any way that I can start the service
    present in a mapped network folder.

    PS: The registry key ImagePath in regedit --> HKLM --> -->system--

    >CCS-->services --> "my service" points to the network drive location.
    I tried providing the logon account which has the network credentials
    under it's properties, but it also didn't work either.
    Is there any workaround to get it to work?

    Tuesday, March 31, 2009 7:15 PM

All replies

  • Hi,

    I am not sure, you may need to check IIS metabase for configured services using ADsutil.vbs utility.

    + In Run, type Services.msc
    + In the Services snap-in, under Name, verify the IIS services that are installed on the computer.
    + In Run, type cmd.
    + Type command cd HardDisk\inetpub\adminscripts  in command prompt.
    HardDisk = hard disk where IIS is installed
    +To verify that an IIS service is configured in the metabase,type the following command at the command prompt, where ServiceName is the IIS service that you want to verify in the IIS metabase:
    Adsutil.vbs enum ServiceName

    For example, to verify that the IIS metabase contains configuration information for the FTP Publishing Service, type Adsutil.vbs enum MSFTPSVC.

    If you receive an error message that is similar to the following, the IIS service may not be installed correctly

    The path requested could not be found.

    6. After you determine the configuration differences between the information that is stored in the metabase and the services that are running on the computer, install or remove services on the computer. To do this, follow these steps:
    1. Click Start, click Run, type Appwiz.cpl, and then click OK.
    2. Double-click Add/Remove Windows Components.
    3. Double-click Internet Information Services (IIS).
    4. Click to select or click to clear the check boxes for the services that you want to configure, and then click Next.
    5. Follow the prompts on the screen to complete the Windows Components Wizard.

    Let me know if this helps.


    • Proposed as answer by Asha M Wednesday, April 1, 2009 4:47 PM
    Wednesday, April 1, 2009 4:46 PM
  • Hi,

    Thanks for the reply. As suggested, I tried installing the network services windows components and then tried to start the service, with this I got the different error message "Access is denied". Any idea how to workaround this?

    Thursday, April 2, 2009 8:16 AM
  • Hi,


    I am not sure about this behaviour.

    Have a look at below links:





    Important Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.


    hope this helps.




    • Proposed as answer by Asha M Tuesday, May 26, 2009 4:05 PM
    Tuesday, May 26, 2009 4:04 PM