locked
Run Project doesn't show canvas RRS feed

  • Question

  • This is driving me nuts - I created a page with a couple of slider controls and then all text. I created the slider controls and tested them, and everything worked and displayed just fine when I ran the project. I added several text boxes just to pretty things up, then ran the project again - it builds just fine (no errors) but when the browser opens, there's nothign there. The Map shows my page, but when I double click, nothign happens. the canvas isn't displaying at all - zero page elements...heck, zero PAGE!

    Any clues?

    UPDATE: I re-created my project, deleted my sliders and re-added them, with the same code behind, and now everything is displaying. Crappy solution, but at least it's working. Still, anyone have any clue as to why running the project wouldn't display the page in a browser?

    • Edited by ST-DCurtis Tuesday, April 20, 2010 5:19 PM updated
    Tuesday, April 20, 2010 5:05 PM

All replies

  • As an update, I re-created my project, and re-added my sliders and code behind and it worked. Displayed like a charm when I ran it. Kind of a crappy workaround, but at least it's working. Still not sure what happened...
    Tuesday, April 20, 2010 6:02 PM
  • Keep in mind this is a guess, but if it was a SL app, there may have been an exception on loading, which shows up as a blank page, and a yellow symbol in the lower left.  Hard to see sometimes.
    Tuesday, April 20, 2010 6:32 PM
    Moderator
  • Thanks, Chuck. It is, indeed, a Silverlight app, and there was an exception. The browser I had set as default didn't display any errors. I loaded in IE8 and sure enough..not sure how to fix it, but I guess it's a moot point now. Thanks for the tip!
    Tuesday, April 20, 2010 8:26 PM