Static Parameter Default Values in SSRS 2016 For Mobile reports RRS feed

  • Question

  • in another blog, this was an answer to the parameter issue for Mobile report publisher. While I understand that the Mobile and Paginated report parameters work differently, I have yet to find a good response to HOW do you set the Default Value for a Stored Procedure with a parameter in Visual Studio, then deploy to the new SSRS 2016 reporting Web server WITHOUT getting a blank result set? ANY instructions...step by step would be incredibly helpful to those of us that are new to SSRS and Mobile report builder. THANK YOU. Here is what was a response I found after two days of searching for an answer.

    In SSRS, the shared dataset used by mobile report needs to return static data. The variable appears in shared dataset query needs to be assigned a value.

    In your scenario, you need to declare parameter @Hierarchy then assign values for it in query. Please refer to sample below:

    declare @group varchar(30) = 'NA';
    SELECT TOP 1000 [SalesTerritoryKey]
      FROM [AdventureWorksDW2008].[dbo].[DimSalesTerritory]
      where [SalesTerritoryGroup] = @group

    If you have any question, please feel free to ask.

    Tuesday, July 12, 2016 7:36 PM


  • Hi PLPeeT,

    According to your description, you want to know how to specify a default value for a parameter in the stored procedure which is used in a shared dataset for Reporting Service 2016 mobile reports. Right?

    To set a default value for a shared dataset query. You can specify a value for the parameter at query design side. Go to Reporting Service Web Portal -> select New and choose Dataset option -> create a shared dataset in Report Builder -> choose the corresponding data source -> select the needed stored procedure and give the parameter a value at Function Parameters section. Then you will see the data in Report Server.

    If you still have any questions, please feel free to ask.
    Xi Jin.

    • Proposed as answer by Xi Jin Friday, July 22, 2016 6:31 AM
    • Marked as answer by Xi Jin Saturday, July 23, 2016 2:32 AM
    Thursday, July 14, 2016 6:01 AM