locked
wcf-basicHTTP send port ignoring maxconnections settings in .config file (throttling/limitting max concurrent connections) RRS feed

  • Question

  • Hi all,

    I have in implementation where I'm sending messages to a partner using WCF-BasicHTTP. De webservice on the partner side can only handle 10 concurrent connections, else it fails and I get an error 500 back. I have been searching for a way to throttle/limit the concurrent connections to be opened.

    I found below which needs to be entered in the BizTalk configuration files (32 + 64 bit)

    configuration>
       <system.net>
          <connectionManagement>
              <add address = "http://ws.webservice:8888" maxconnection = "10" />
             <add address="*" maxconnection="10" />
          </connectionManagement>
       </system.net>
    </configuration>

    But it seems to be ignoring it (yes everything restarted even te server itself). When using Fiddler I see that it opens about 20 connections at once, causing the service on the other side to fail.

    What am I doing wrong here? How can I throttle/limit the outgoing connections to this webservice.

    • I want to prevent using a special orchestration pattern for this
    • I have tried ordered delivery, this works fine, but it's too slow. (peak times 200-1000 messages every 15 mins, so before the messagebox is empty the next batch arrives
    • I DO NOT have control over the webservice on the other side (nor can/or will they change the amount of concurrent connections on their side (Limit of boundary system)

    Thanks in advance

    Patrick



    • Edited by PatrickLws Monday, September 25, 2017 7:37 PM
    Monday, September 25, 2017 7:31 PM

All replies

  • Have you tried the address without the http:// and port number, e.g.

        <add address = "ws.webservice" maxconnection = "10" />

    Tuesday, September 26, 2017 12:37 AM
  • Hi,

    Yes I did.. I even tried putting extra wildcards in etc..

    Could it be because it runs through a proxy ?

    regards

    Patrick

    Tuesday, September 26, 2017 7:29 AM
  • Answered my own question regarding the proxy.. I only created a wildcard entry with maxconnection 3 and it is still opening more connections...

    Patrick

    Tuesday, September 26, 2017 7:59 AM
  • Have you tried using WCF-Custom with the BasicHTTP binding to see if that has the same issue?
    Wednesday, September 27, 2017 9:52 PM
  • Hi

    Yes I did. Same problem

    Thursday, September 28, 2017 9:47 AM