none
SP 2013: OOTB Custom form deletes itself. RRS feed

  • Question

  • Greetings,

    I’m using SP 2013 to create custom task forms, but also editing the aspx code to make some columns read only, add comments, etc. Within SPD, in List and Libraries – Tasks – Forms, I create three new edit forms. AAA_Abcdefgh111.aspx, AAA_Abcdefgh112.aspx, AAA_Abcdefgh113.aspx. Each used for a separate task in a workflow.

    I then custom edit these forms for read only columns, etc.

    Once saved and I preview in browser, guaranteed one of the three forms show in IE as blank. Upon reviewing the aspx code I see there is nothing within the <ZoneTemplate></ZoneTemplate>. Its as shown = blank. When place back the missing aspx code (saved to external file), the form in question works and one of the other three forms becomes blank.

    What the @%$#!!

    Wednesday, January 25, 2017 3:20 PM

All replies

  • follow the steps in the link below to create the task form:

    https://msdn.microsoft.com/en-us/library/office/dn518136.aspx

    Wednesday, February 1, 2017 2:25 AM
  • Victor,

    Thank you for the link. We've been trying to keep development OOTB, but have reconsidered to use Visual Studio. Unfortunately this reduces the development / support pool within our organisation, but the VS benefits are too many to ignore.

    The original issue of forms clearing themselves is still unresolved. I've worked through it, by repeating the same procedure until it actually stuck (this is insanity right?). Nevertheless, future development using SPD is probably not going to happen.

    Kind regards,

    Monday, February 6, 2017 2:33 PM