none
Cannot reinstall SONY Mediago RRS feed

  • Question

  • Hi All,

    I had some issue's with WMP when I first built my machine. (It was finally down to registry keys pointing to the drive letters that had been created by default when the PC was first built). During the troubleshooting process I was advised to remove all media type applications I might have loaded. The only one is SONY Mediago, that I use for my PSPgo. The uninstall failed. Unfortuneatly I don't remember the error, but I think it had something to do with syntax being incorrect. I then went through and delete every reference I could find to Mediago, in file folders and via regedit.

    I finally managed to get WMP sorted out and then tried to reinstall Mediago v1.6. I now get the following message.

    ERROR: There was a problem initializing the installer. Your system has not been modified.

    Earlier on I also saw a message that suggested Mediago was still installed even though I've done my best to clear it from my PC and can't find any reference to it any where. I have tried moving mediago_setup.exe to another drive, on the same machine, and another account, but get the same ERROR message. I've deleted mediago_setup.exe and downloaded a new copy from work and home, but still get the same issue.

    Anybody know where the last piece of Mediago, from the original install, might be hiding and preventing me from installing again?

    Wednesday, April 6, 2011 7:45 PM

All replies

  • I would recommend to ask this questin in a Sony or PSPgo Forum, this is more a kind of Installer than Windows Embedded issue.

    If it's a MSI installer, you can try the /l * X:\log.log switch.

    Otherwise you can try to monitor the Setup with procmon to figure out what gets checked.


    "Mark/Propose As Answer" if you got one.
    Wednesday, April 6, 2011 11:00 PM
  • Hi Knarz,



    Thanks for the reply. I was rather hoping somebody might be able to suggest a where I could look in Windows 7 to find the last of the installer, that I obviously haven't cleared?

    Saturday, April 9, 2011 6:50 AM
  • Try looking in C:\Program Files (x86)\Common Files to see if anything was left over.

    -Sean


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - ProGuide to WES 7, XP Embedded Advanced, WEPOS / POS for .NET Step-by-Step
    Saturday, April 9, 2011 1:55 PM
    Moderator