none
wcf service (netTCPBinding) running in IIS but showing error in Visual Studio RRS feed

  • Question

  • I hosted my service in local IIS. I can browse the service via IIS without any errors but when i try to launch it in Visual Studio, It displays error "Could not find a base address that matches scheme net.tcp. Only http is registered."

    I am working the same solution on another PC. It os working fine without any errors via IIS and VS as well.

    BTW on the PC it is not working, it runs windows 7 and IIS 7.5. Another PC runs Windows 8 and IIS 8.

    Thanks


    • Edited by Asif Bhat Friday, August 28, 2015 1:57 AM
    Thursday, August 27, 2015 7:44 AM

All replies

  • Hi Asif Bhat,

    According to this problem, when we host WCF service to IIS with .nettcpbinding, it worked.

    Because, Since IIS 7, the NetTcpBinding or other non - HTTP protocols, such as Bindings can

    be hosted  on IIS directly.

    But when we try open it with browse  via visual studio, it will display a error. Because, the browse

     is based on HTTP protocol.

    Best Regards,

    Grady

    Friday, August 28, 2015 5:48 AM
    Moderator
  • I accept but how come it works on my another computer? In that computer I have IIS 8 intalled with windows 8.
    Friday, August 28, 2015 7:13 AM
  • Hi Asif Bhat,

    About this issue, I guess your some windows service for net.tcp is not enable.

    If so, please make sure the following services is enable for net.tcp.

    Net.Tcp Listener Adapter

    b.     Net.Tcp Port Sharing Service

    If not then enable and start both services.

    Next, run your visual studio as administrator. Then right click the project chose Properties.

    and left click web option. You will see the servers, the visual studio default is IIS express.

    So you need to  change it  manually as IIS.

    I hope that will be helpful to you.

    Best Regards,

    Grady

    Monday, August 31, 2015 5:57 AM
    Moderator
  • Hi

    I did everything even the services are running but the  same results.

    Not working on other PC's only mine. lol

    In other PC's it is showing only Http is registered. Mine works fine. Although the solution is same. no change in web.config.

    Thanks


    • Edited by Asif Bhat Wednesday, September 2, 2015 4:59 AM
    Wednesday, September 2, 2015 4:59 AM
  • Hi Asif Bhat,

    According to this issue, I guess in your local machine not installed IIS Express, so when you

    host your WCF Service in IIS,  then the visual studio view in browser  from IIS. So it will

    worked fine.

    Best Regards,

    Grady

    Monday, September 7, 2015 8:36 AM
    Moderator