none
TrimLeadingZerozForNumc Property RRS feed

Answers

  • Hey, I heard back from the MS Support team (thanks Mandi for the quick response!). They said you should install CU 3 to get the hotfix you needed. I am guessing you may need to remove CU 4 and then install CU 3 to get past the hotfix launch condition.

    They said that they will be identifying why CU 4 did not have the fix and will probably be attempting to fix the issue in the subsequent CU, so this would be CU 5. I do not know a date for this but if I had to guess it would be sometime Q1 2012. I am just guessing on this date based on the approximate time between CU releases.

    -- Update:

    CU 4 should include all previous hotfixes based on new feedback from Microsoft. If the SAP binding hotfix is not getting applied then I am wondering if some prerequisite is not installed or setup properly and the hotfix is not run when the CU 4 installer runs. You should pursue this matter with MS Support directly if CU 4 does not install properly for you.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Tuesday, January 24, 2012 2:02 AM
    Moderator

All replies

  • I looked at CU 3 (http://support.microsoft.com/kb/2557150) and then CU 4 (http://support.microsoft.com/kb/2604327) and it does not look like the fixes from CU 3 were rolled into CU 4. So the fix is not in CU 4. If you apply CU 3 it has it - KB 2539412.

    I will reach out to the MS Support team to see if this is supposed to be like this or if this is wrong. I had not heard the CU rollup strategy had changed at all.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Monday, January 23, 2012 11:54 PM
    Moderator
  • Hey, I heard back from the MS Support team (thanks Mandi for the quick response!). They said you should install CU 3 to get the hotfix you needed. I am guessing you may need to remove CU 4 and then install CU 3 to get past the hotfix launch condition.

    They said that they will be identifying why CU 4 did not have the fix and will probably be attempting to fix the issue in the subsequent CU, so this would be CU 5. I do not know a date for this but if I had to guess it would be sometime Q1 2012. I am just guessing on this date based on the approximate time between CU releases.

    -- Update:

    CU 4 should include all previous hotfixes based on new feedback from Microsoft. If the SAP binding hotfix is not getting applied then I am wondering if some prerequisite is not installed or setup properly and the hotfix is not run when the CU 4 installer runs. You should pursue this matter with MS Support directly if CU 4 does not install properly for you.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Tuesday, January 24, 2012 2:02 AM
    Moderator
  • Thanks Ben, for your quick response.

    I'll be removing the CU 4 and installing the CU 3.

    Willians

    Tuesday, January 24, 2012 9:22 AM
  • Sorry... I've already found the property... Thanks again!


    Wednesday, January 25, 2012 9:44 PM
  • Thank you. Yes - the TrimLeadingZerozForNumc SAP property is available after installing BAP 2.0 CU4. Specifically:

    WCF-Custom adapter:

    1. When configuring the send port/receive location, select the WCF-Custom Type. Click Configure.
    2. In the Binding tab, select sapBinding.
    3. Click DataTypesBehavior.

    trimLeadingZerosForNumc property is at the bottom.


    WCF-SAP adapter:

    1. When configuring the send port/receive location, select the WCF-SAP Type. Click Configure.
    2. In the Binding tab, select DataTypesBehavior and click the configure button.

    TrimLeadingZerosForNumc property is at the bottom.


    Sunday, February 19, 2012 3:39 PM
    Moderator