locked
Xamarin VS update 4.3.0.795 fails to install RRS feed

  • Question

  • User299549 posted

    Hello,

    I wanted to point this out, in case others are running into this. I saw the update today and went to install it. However, with Visual Studio Community 2015, trying to install Xamarin VS update 4.3.0.795 throws an error:

    This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package.

    Wednesday, March 29, 2017 4:24 AM

Answers

  • User45913 posted

    Try deleting things in C:\Users\%USERPROFILE%\AppData\Local\MonoDevelop-4.0\Cache\TempDownload

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Wednesday, March 29, 2017 8:10 AM

All replies

  • User151034 posted

    same error for me, I thought it is because of a corrupted download!

    Wednesday, March 29, 2017 7:33 AM
  • User45913 posted

    Try deleting things in C:\Users\%USERPROFILE%\AppData\Local\MonoDevelop-4.0\Cache\TempDownload

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Wednesday, March 29, 2017 8:10 AM
  • User90290 posted

    @ZacharyWenta @ChristianSvrd - Depechie's suggestion is what I'd go with. Please try that. Failing that please DM me for a direct link!

    @Depechie Thanks for bringing this to my attention :)

    Wednesday, March 29, 2017 10:37 AM
  • User299549 posted

    Depechie's answer worked for me, thank you good sir

    Wednesday, March 29, 2017 10:48 PM
  • User263012 posted

    @Depechie said: Try deleting things in C:\Users\%USERPROFILE%\AppData\Local\MonoDevelop-4.0\Cache\TempDownload

    Did the job. Thanks

    Thursday, March 30, 2017 12:16 PM
  • User151034 posted

    Thanks @Depechie

    Monday, April 3, 2017 7:23 AM
  • User201467 posted

    Thanks, it worked

    Monday, April 10, 2017 3:21 PM
  • User230799 posted

    @Depechie said: Try deleting things in C:\Users\%USERPROFILE%\AppData\Local\MonoDevelop-4.0\Cache\TempDownload

    Thanx @Depechie its working

    Tuesday, April 18, 2017 8:03 AM
  • User317661 posted

    Hi Guys, Try deleting things in C:\Users\%USERPROFILE%\AppData\Local\MonoDevelop-4.0\Cache\TempDownload

    Did not work for me. Please is there another solution?

    Tuesday, April 18, 2017 9:22 AM
  • User299549 posted

    @chuka said: Hi Guys, Try deleting things in C:\Users\%USERPROFILE%\AppData\Local\MonoDevelop-4.0\Cache\TempDownload

    Did not work for me. Please is there another solution?

    Try closing VS, then delete all files in that folder above, then try re-opening VS and installing the update

    Tuesday, April 18, 2017 12:50 PM
  • User317661 posted

    @Programmer17 said:

    @chuka said: Hi Guys, Try deleting things in C:\Users\%USERPROFILE%\AppData\Local\MonoDevelop-4.0\Cache\TempDownload

    Did not work for me. Please is there another solution?

    Try closing VS, then delete all files in that folder above, then try re-opening VS and installing the update

    Thanks @Programmer17 for your replay. I worked for Workbook and Inspector install but the xamarin update kept failing.

    Sunday, April 23, 2017 4:13 PM
  • User90290 posted

    @chuka Are you still having issues with this?

    Monday, April 24, 2017 10:26 AM
  • User317661 posted

    no @AlanClark . Its ok now. A new heavier update downloaded and installed successfully. Thank you.

    Wednesday, April 26, 2017 9:00 PM
  • User134020 posted

    I'm having the issue of fails to install for Xamarin 4.5.0.476. Using VS Community 2015. Before-mentioned solution didn't work for me. My current Xamarin is 4.5.0.475.

    Monday, May 29, 2017 7:47 AM
  • User174493 posted

    Hi guys, same issue here. Tried @Programmer17 suggestion but still not working. @AlanClark can you help please? I need the latest version of Xamarin for VS2015. Thanks!

    [UPDATE] - Solved I just solved this way: 1) Close all VS instances 2) Delete files in C:\Users\%USERPROFILE%\AppData\Local\MonoDevelop-4.0\Cache\TempDownload 3) Restart the PC and download again. Without restarting the PC it will not work and will keep giving you the error.

    Thanks

    Saturday, June 3, 2017 11:37 AM
  • User193480 posted

    @AlanClark I am having the same issue with version 4.5.0.486 installing in VS2015. I have tried the steps above including restarting windows after deleting the files from the Cache directory. Is there anything else to try? I receive the same error when running the msi from the TempDownload directory.

    [UPDATE] I downloaded the version from the Xamarin download page and was able to successfully install.

    Thanks, Doug

    Wednesday, June 28, 2017 3:27 PM