none
Debug Capability Test (LOGO) -Failed RRS feed

  • Question

  • I have a problem regarding to Debug Capability Test (logo).

    I got this error when the testing is finish.

    " The test timed out waiting for the kernel debugger to break in."

    Anyone that encountered this problem?

    I hope anyone can help me to solve this.

    Thanks

    Thursday, December 13, 2012 4:54 AM

All replies

  • Hi Hyasmine, I'm the PM on the team that owns this test. Can you provide the logs for this failure and perhaps answer a few questions?

    1. What protocol were you trying when this failed in this manner?
    2. If you were trying USB were you using the port that supports debugging? On most systems only one of the USB ports actually supports debugging so you'd need to use the correct one.

    Friday, December 14, 2012 7:17 PM
  • Hi Matt,

    what do you mean what protocol?

    I have the SUT and DebugHost computer those are required in this testing. I didn't used any usb.

    After I run the test I got that error.

    Monday, December 17, 2012 2:48 AM
  • So the Test in question here will allow you to try several protocols for debugging (serial, USB2, 1394, Network). So what wire are you using to connect the target and the debug host for them to 'talk' to each other for the test?

    Without knowing which one is failing for you it's hard to say what the possible error might be. Also, do you have the actual log files to share or at least the failure from the log?

    Monday, December 17, 2012 7:24 PM
  • I used UTP and they are connected to a switch. I have tried the NET and the USB2 but there are different error.

    This picture I used "NET"

    In this I used "USB2"

    Wednesday, December 19, 2012 1:52 AM
  • Hi Matt,

    Do you have any idea why my test is failing?

    Thanks


    • Edited by Hyasmine Thursday, December 27, 2012 3:10 AM wrong gramar
    Thursday, December 27, 2012 3:10 AM
  • My NIC is INTEL 82579V. Is it because the model of my NIC that is why I got this error?

    I hope anyone can help me with this error.

    Thanks.


    • Edited by Hyasmine Thursday, January 3, 2013 6:45 AM
    Thursday, January 3, 2013 6:24 AM
  • Sorry for the delay in responding, I was out on vacation. I will talk to my contacts in the dev/test team and try to get back to you by Monday. Thanks.
    Friday, January 4, 2013 12:37 AM
  • Okay.. I have some things to report back:

    For USB -> you need to specify USB not 'USB2' as the value. The documentation is a little difficult to interpret on this part it seems and we're going to look at fixing it up.

    For NET -> We'd need the HCK test result package to do more investigation (the screenshot isn't enough info it seems). But one question: did you specify the NetHostIP and anything else necessary per the help doc for the Debug Capability Test (Logo) topic?

    Friday, January 4, 2013 6:01 PM
  • I change the USB2 to USB and I got the an error same with the first image above.

    For the NET, I didn't change anything on the NetHostIP and with the other parameter just the value of Transport.

    Where am I gonna send HCK test result?

    Monday, January 7, 2013 5:43 AM
  • I am hitting the same issue on virtual Machine . only use e1000 nic can make the job pass ,While failed when using other emulated network card (eg ,virtio-net ,rtl8139) and protocols (eg serial) . 


    Best Regards, Mike

    Monday, January 7, 2013 5:49 AM
  • For NET you need to add in the HostIP parameter as well. Did you put that in as well? Additionally if you have more than 1 NIC you must specify which NIC to use under the test.
    Monday, January 7, 2013 5:41 PM
  • No, I didn't. What should I put on the HostIP? The server's IP?

    I have 2 NIC but only 1 NIC that I put LAN connection.

    Tuesday, January 8, 2013 1:52 AM
  • I tried to change the HostIP with the IP of the SUT but still have the error like on the 1st image.
    Tuesday, January 8, 2013 2:12 AM
  • For this test with USB, please make sure that bwlow configuration in SUT,HOST and HCK server.

    For BIOS Binary, please make sure that "Debug Port Table 2 (DBG2)" table is present in ACPI structure.

    Microsoft Debug Port Table 2 (DBG2) --> http://msdn.microsoft.com/en-us/library/windows/hardware/hh673515.aspx

    download this File name: microsoft-debug-port-table-2.docx 

    (The computer that you're trying to certify is the System under Test (SUT). The second computer is the Host.)

    SUT/HOST platform: (set Secure Boot to disabled in BIOS Setup )

    1. please connected “Ajays USB2.0 Debug cable” from SUT to HOST on USB 2.0 ports. (you can use USB Debug Viewer to check that USB Port 1)

    2.To install x64 Kernel Debugger tool to SUT and HOST. (X64 Debuggers And Tools-x64_en-us.msi )

    3.Disabled the firewall for SUT and HOST machine.

    HCK Server:

    1.In the Parameters window Transport field, enter one transport type and the name is "USB" (please do not type "USB2" )

    2.Click drop down list and choose DebugHost machine.

    • Proposed as answer by Jo OSantos Thursday, April 11, 2019 4:11 PM
    Tuesday, January 8, 2013 4:34 AM
  • Hi, Hyasmine

    Pls try following steps 

    1.the SUT you should have 2 NICs ,one is used for commnucate with windbg on another host (let's call it NIC A ,and it should listed in MSFT kernel debug support list )

    2.Prepare for another host as debug host 

    3.In the job parameters 

    the value of Transport  is "net"

    the value of NetHostIP is the debug host ip

    the value of BusParams is the PCI address of NIC A ,you can find it on the SUT device manager 

    This will make my job pass ,HTH to you 


    Best Regards, Mike

    Tuesday, January 8, 2013 6:00 AM
  • not sure whether I am right ,I think you should put them 2 in LAN connection .one is used to commnunicate with HCK Controller ,another one is used for kernel debug.

    During my test ,I find the NIC used for kernel debug can not ping HCK Controller successfully 


    Best Regards, Mike

    Tuesday, January 8, 2013 6:11 AM
  • Sorry, I only have One NIC on my SUT. What is the windbg?

    My NIC is not listed here http://msdn.microsoft.com/en-us/library/windows/hardware/hh830880.aspx

    I can't find the PCI address. What do you mean PCI address? can you give me a printscreen or sample of the PCI adress?

    Thanks

    Tuesday, January 8, 2013 8:56 AM
  • Hyasmine 

    >Sorry, I only have One NIC on my SUT. What is the windbg?

    I tried only one NIC on my SUT ,guest always become no-response status.

    >My NIC is not listed here http://msdn.microsoft.com/en-us/library/windows/hardware/hh830880.aspx

    I think you must use one if you decided to use NET protocol to run this job 

    >I can't find the PCI address. What do you mean PCI address? can you give me a printscreen or sample of the PCI adress?

    win+R--> press devmgmt.msc--->right click Network Adapter-->properties--->details--->location infomation ,




    Best Regards, Mike

    Tuesday, January 8, 2013 9:58 AM
  • I tried the NetHostIP with the debug host ip and BusParams with the PCI address still the test is failed. I got this error "The test timed out waiting for the kernel debugger to break in" like what in the image above.

    Wednesday, January 9, 2013 5:28 AM
  • Can you confirm your SUT have 2 NICs ,one of them is listed in kernel debug listed in http://msdn.microsoft.com/en-us/library/windows/hardware/hh830880.aspx . ?

    Best Regards, Mike

    Wednesday, January 9, 2013 5:37 AM
  • I have a mistake on my previous reply I only have 1 NIC and Intel 82579V is my NICs model. It is not listed on the site. Is that the reason why I got that error?

    Thanks

    Wednesday, January 9, 2013 6:12 AM
  • I don't think so ,I try w/ the NIC does not list on the site ,the log will shows you should use the NIC located in http://msdn.microsoft.com/en-us/library/windows/hardware/hh830880.aspx . ?

    I have hit your error when using isa_serial to do kernel debug ,I think the root cause it misaken configuration .


    Best Regards, Mike

    Wednesday, January 9, 2013 6:41 AM
  • No, the log didn't show what NIC should I use. How can the isa_serial do the kernel debug? What configuration should I do? Can we talk via skype? If it is ok with you?

    Thanks

    Wednesday, January 9, 2013 7:36 AM
  • Connect the SUT and Debug host via serial cable . details config referring to http://msdn.microsoft.com/en-us/library/windows/hardware/ff542187(v=vs.85).aspx .

    Sorry I do not have a skype .



    Best Regards, Mike

    Wednesday, January 9, 2013 9:42 AM
  • If your NIC isn't listed then it is not considered able to support NET debugging for the tests thus it will fail. Keep in mind, we are speaking of the NIC on the SUT not the HOST machine.

    I think you should fall back to USB debugging as noted in a few other posts.

    Wednesday, January 9, 2013 9:06 PM
  • I'd like suggest you to try serial port. it is also supported by HCK.

    Sean Ge

    Thursday, January 10, 2013 8:59 AM
  • So I need a serial card because there is no serial port on the board that I am using? Is there a third party hardware needed when I use the serial port?
    Thursday, January 10, 2013 9:48 AM
  • If your SUT has USB and that is already certified as a board (meaning it passed logo) then one of the USB ports on it should work for the test. For USB though it generally is only 1 port that actually supports debug and you'll want to follow the instructions on setting it up as it's not the most straightforward process like plugging in a PnP device.

    I believe that SeanGe was suggesting serial as it's a basic default that works on systems which have serial (but as you note many do not).

    Friday, January 11, 2013 12:06 AM
  • Where can I found the instructions? I need a USB cable (both male) to be able to connect the SUT and Host?
    Friday, January 11, 2013 5:44 AM
  • The link that you gave me support windows XP and Vista, is this ok for win8? What debug cable that is needed on this test?
    Tuesday, January 15, 2013 4:28 AM
  • Yes, this applies to Win8 as well. And the 'debug cable/device' is described in the article (you'll have to search for one the article says. I cannot recommend one versus any other device/cable)
    Tuesday, January 15, 2013 6:19 PM
  • When I use the USBVIEW there is no Port 1 is exposed on my unit how can I find the port 1?

    Thanks

    Wednesday, January 16, 2013 3:31 AM
  • So that's not one I can answer online.. sadly each system has a different setup in terms of which exposed USB port is the actual one for debugging. The only way to discover it is trial-and-error I fear...
    Thursday, January 17, 2013 9:21 PM
  • How about I use the serial? What configuration should I do?
    Friday, January 18, 2013 5:02 AM
  • Do you have serial cable port on your SUT ?If no ,i don't think you can do it succesfully.

    Best Regards, Mike

    Friday, January 18, 2013 5:40 AM
  • Yes I have (male), is it an ordinary serial cable? Why I can't do that successfully?
    Friday, January 18, 2013 7:08 AM
  • Could you tell me how you configure it ?


    Best Regards, Mike

    Friday, January 18, 2013 7:52 AM
  • Pls run it manually first .Let's call the SUT Target host , and the host you use to install windbg  Debug Host 

    steps:

    1. Connect Target host and Debug host via serial cable

    2.install windbg on Debug host .

    3.in the Target host ,open debug mode (msconfig --->Boot tab-->advanced options-->check debug 

    debug port -->COM1 BAUD rete to 115200

    4.on the debug host 

    Symbols search path set to SRV*C:\symbols\*http://msdl.microsoft.com/download/symbols

    5on the debug host  open windbg--->kernel debug-->Com tab ---> check pipe and reconnect ,click ok

    6.reboot target host  ,

    7you will find windbg can remote debug kernel debug and ntkrnlmp.pdb file existed in C:\symbols

    8.Then re-run the job on HCK


    Best Regards, Mike

    Friday, January 18, 2013 8:42 AM
  • Hi,

    I already passed this test just follow the instruction on this link.

    http://msdn.microsoft.com/en-us/library/windows/hardware/hh439346%28v=vs.85%29.aspx

    Thanks

    Tuesday, January 22, 2013 2:29 AM
  • Hi,Hyasmine

    Congratulations ! But I still wonder how you make the job pass even one of your NICs in SUT is not listed in http://msdn.microsoft.com/en-us/library/windows/hardware/hh830880.aspx . while your job passed via NET protocol. 


    Best Regards, Mike

    Tuesday, January 22, 2013 2:51 AM
  • I also wondering why is this test passed using NET, I just try to follow the instructions. anyway the important is I passed the test.

    Tuesday, January 22, 2013 3:05 AM
  • Hello all,

    my recommendation after 10 times I have tried this test with same problem - disable firewall on host computer

    Monday, June 29, 2015 1:59 PM