locked
VSWinExpress.exe - Entry Point Not Found

    Question

  • I've spent some time developing Metro-style apps in the Windows 8 Consumer Preview and the Release Preview using Visual Studio 2012 Express RC.  A couple weeks ago, however, VS2012 began encountering an error at launch and has failed to start every time since then.  The text of the error is as follows:

    "VSWinExpress.exe - Entry Point Not Found
    The procedure entry point _Atomic_fetch_add_4 could not be located in the dynamic link library C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\VSWinExpress.exe."

    I tried uninstalling and reinstalling the software, but after numerous system restarts and downloads the problem still persists.  Searching the Internet for similar problems yielded only topics relating to Windows Server 2000 and Microsoft Visual Studio 2010.

    I am having this issue only on my main development machine, a custom build running the 64-bit edition of Windows 8 Release Preview on an Intel i7 3770k.  The problem does not occur on my laptop, which is running the same edition of the software on a similar processor (one of the earlier Intel i7 mobile processors).  My projects directory is stored in my local SkyDrive directory and synced between both the desktop PC and laptop PC.

    Any assistance would be appreciated so I can get VS 2012 Express RC working on my main development machine again.

    Thursday, August 2, 2012 4:54 PM

Answers

All replies

  • Hello Aaron,

    did you happen to install the Office 2013 preview?  if so then there is an issue that the July update fixes

    update: http://www.microsoft.com/en-us/download/details.aspx?id=30178

    much appreciated,

    mike

    Friday, August 3, 2012 8:06 PM
    Moderator
  • I have been having this same issue, but I didn't install Office 2013. Any ideas what else could be the cause?

    partiuclar idiom

    Thursday, August 16, 2012 5:53 PM
  • Sunday, August 19, 2012 11:34 PM
  • No one has still got the answer to it?
    Strange?

    I am also facing the same issue.

    Please help !

    Friday, September 7, 2012 10:11 PM
  • Did you try the update that Mike and tauneutrino suggested?

    --Rob

    Friday, September 7, 2012 10:43 PM
    Owner
  • I tried this fix, but it did not work!

    "RC Updates does not apply, or is blocked by another condition on your computer."

    Monday, September 10, 2012 7:53 AM